Jump to content

Mechman Alternators
Welcome to SMD Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Something wrong with my Mechman?


79 replies to this topic

#13
miniSPLlancer

miniSPLlancer

    Bass Keeps Me Broke

  • Members

  • 653 posts
  • Gender:Male
  • Location:AZ
Garage View Garage


Yeah call Eric he'll take care of you. I had a bad rectifier on my first unit, and they took care of the problem asap.


Biggest problem for me is sending it to the US and getting it back, that would cost me a lot of money wich sucks since i already spent A LOT on this thing :S

I don't wanna bet on it, but I would like to think you and Mechman can work something out with shipping back to the U.S.

2011 Mitsubishi Outlander
Pioneer AVH-P4400

 

 

SOLD EVERYTHING EXCEPT TRUCK AND DECK!!!!!!!!!!!!

 

 

 

 

 


#14
extremeauto

extremeauto

    130db

  • Members

  • 487 posts
  • Gender:Male
  • Location:Monmouth il
  • Interests:cars car audio

I'm not gonna gang up on Mechman as my issues are really at idle, on my low power at 1k rpm and up I'm getting 14.6-14.9v ... Soon as I get to 700 on dash it drops to 13.6-12.7-12.3-12.2 .... Apparently my car sucks???

hmmm sound like my 200 amp universal mechman i had to send back and PAY to have fixed...
1995 Honda passport 3.2 4x4 Frankenstein on a budget ballistics sound deader (roof only so far) kenwood mp3 usb audio control 3 (upgrading) hifonics mx-3 3 sets of massive px5 5.25s 3 sets of massive tweets phonix gold 5.25 componets x2 massive nx4 nano 200x4 mids sony xplod 600x4 watt high's 2 Fi bl fully loaded box walled @31ish hz 13.2 cube box/wall massive DB8000 Excessive amaperge 250 amp alt wir extrnl regulator daul runs of xs power xpflex 0 gauge big 3 raptor 0 gauge power/ground wire full run suriken 45 amp hour x3 shriken bt-120 batts,interstate 1100CA semi batt scytek galaxy 2way alarm still upgradeing!

#15
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,638 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D
Well see, first off, im gonna record a video tomorrow using a single DD m2a wired at 0.5 ohms with a rise to 1.4 ohms @ 42 hz , 4 runs of 0 gauge and a big ass HC2400 on front, and yes, that battery its on perfect shape...

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 & 2014 Bass Race 149.9 Champion!

 

2 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 Massive 15" subs and small power, http://www.stevemead...-bandpass-wall/


#16
shogen

shogen

    155db

  • Members

  • 2,125 posts
  • Gender:Male
  • Location:New Jersey
  • Interests:Car audio, computers and vageena...


I'm not gonna gang up on Mechman as my issues are really at idle, on my low power at 1k rpm and up I'm getting 14.6-14.9v ... Soon as I get to 700 on dash it drops to 13.6-12.7-12.3-12.2 .... Apparently my car sucks???

hmmm sound like my 200 amp universal mechman i had to send back and PAY to have fixed...



I just got mine not even 2 weeks ago...

Pioneer Premier P880PRS [color=#FF8C00;]ll[/color] Front Stage: US Acoustics 4060 - Random speakers currently [color=#FF8C00;]ll[/color] Sub Stage: Crescendo BC3500D - 15" Xcon sealed @ 3.28 cubes [color=#FF8C00;]ll[/color] Electrical:  - Kinetik HC1800(front) [color=#FF0000;]NEW***[/color]DieHard P-2(rear)

beaker[color=rgb(255,0,0);]I know this sounds like a lot of anime bullshit, but it is true.[/color]

 

 


#17
Team_DC-Derrick

Team_DC-Derrick

    Uncle Ruckus, No relation

  • 18+ All Access!


  • 6,547 posts
  • Gender:Male
  • Location:Columbus, Ohio

Well see, first off, im gonna record a video tomorrow using a single DD m2a wired at 0.5 ohms with a rise to 1.4 ohms @ 42 hz , 4 runs of 0 gauge and a big ass HC2400 on front, and yes, that battery its on perfect shape...


and while you are doing that test, dont forget to raise the RPM to see if it fixes the problem, a 2 second check to see if the RPM is the issue can solve alot....

or you can shell out the cash to send it back, with out even testing the RPM, just to find out you need to have it at 4k

i would just try raising the RPM first, before doing anything else...
The DC Integra 3 18s to 6 15 build log


Team_DC-Derrick's Youtube


Team DC Audio

where theres a will theres a wall.......

I just realized Steve has reach Voldemort status, over on JP's site he is the one who will not be named....."We dont speak his name over here, fearing it will destroy us" LOL not even in hush tones


#18
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,638 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D


Well see, first off, im gonna record a video tomorrow using a single DD m2a wired at 0.5 ohms with a rise to 1.4 ohms @ 42 hz , 4 runs of 0 gauge and a big ass HC2400 on front, and yes, that battery its on perfect shape...


and while you are doing that test, dont forget to raise the RPM to see if it fixes the problem, a 2 second check to see if the RPM is the issue can solve alot....

or you can shell out the cash to send it back, with out even testing the RPM, just to find out you need to have it at 4k

i would just try raising the RPM first, before doing anything else...


Yeah sure, once again, i was accelerating to 3K and dropping to 2K when i burped the car, gonna try 3 or 4 different RPMs then and post the video, lets just hope that you are right and i just need to give it a 4-5K acceleration wich i dont mind :peepwall:

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 & 2014 Bass Race 149.9 Champion!

 

2 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 Massive 15" subs and small power, http://www.stevemead...-bandpass-wall/


#19
Team_DC-Derrick

Team_DC-Derrick

    Uncle Ruckus, No relation

  • 18+ All Access!


  • 6,547 posts
  • Gender:Male
  • Location:Columbus, Ohio
When the rpms drop that still lowers the output... Gotta bring it back up during the burp
The DC Integra 3 18s to 6 15 build log


Team_DC-Derrick's Youtube


Team DC Audio

where theres a will theres a wall.......

I just realized Steve has reach Voldemort status, over on JP's site he is the one who will not be named....."We dont speak his name over here, fearing it will destroy us" LOL not even in hush tones


#20
bre2ts

bre2ts

    PROUD INFIDEL!

  • SMD Gold Member

  • 3,194 posts
  • Gender:Male
  • Location:Pordenone Italy


I'm not gonna gang up on Mechman as my issues are really at idle, on my low power at 1k rpm and up I'm getting 14.6-14.9v ... Soon as I get to 700 on dash it drops to 13.6-12.7-12.3-12.2 .... Apparently my car sucks???

hmmm sound like my 200 amp universal mechman i had to send back and PAY to have fixed...

Were you the original owner?

If not you are not covered under warranty.

When I had an issue with mine they fixed it within 1 business day and was all covered under warranty

Feedback 1 | Feedback 2

 
 
you win some, you lose some

#21
extremeauto

extremeauto

    130db

  • Members

  • 487 posts
  • Gender:Male
  • Location:Monmouth il
  • Interests:cars car audio



I'm not gonna gang up on Mechman as my issues are really at idle, on my low power at 1k rpm and up I'm getting 14.6-14.9v ... Soon as I get to 700 on dash it drops to 13.6-12.7-12.3-12.2 .... Apparently my car sucks???

hmmm sound like my 200 amp universal mechman i had to send back and PAY to have fixed...

Were you the original owner?

If not you are not covered under warranty.

When I had an issue with mine they fixed it within 1 business day and was all covered under warranty

bought it brand new from matt @ mechamn was told i used the wrong ring termal on my power lead from the alt.... :bull: i paid for the repair and bought a 0 gauge power wire from them ...hopefully it was my fault ora fluke and i will have no more issues ...sad thing is my stock 70 amp alt ahs took its place for the last 2 month and is holding like a champ.. the mechman lasted 2 months:pardon:

Edited by extremeauto, 10 December 2011 - 11:28 PM.

1995 Honda passport 3.2 4x4 Frankenstein on a budget ballistics sound deader (roof only so far) kenwood mp3 usb audio control 3 (upgrading) hifonics mx-3 3 sets of massive px5 5.25s 3 sets of massive tweets phonix gold 5.25 componets x2 massive nx4 nano 200x4 mids sony xplod 600x4 watt high's 2 Fi bl fully loaded box walled @31ish hz 13.2 cube box/wall massive DB8000 Excessive amaperge 250 amp alt wir extrnl regulator daul runs of xs power xpflex 0 gauge big 3 raptor 0 gauge power/ground wire full run suriken 45 amp hour x3 shriken bt-120 batts,interstate 1100CA semi batt scytek galaxy 2way alarm still upgradeing!

#22
CJ18

CJ18

    System of the Month Winner November '11

  • SMD PARTNER


  • 13,160 posts
  • Gender:Male
  • Location:Florida
All of mine have always reached full power at about 2000-2500rpm. Does your voltage fluctuate while at idle or does it hold solid at 14.5?

Owner- Droppin HZ Car Audio

Email- [email protected]

Web Address- http://www.droppinhzcaraudio.com/

 

DHZ%20Banner_zpswny7inpz.jpg


#23
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,638 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D
Holds solid 14.5 with the engine hot, 14.6-14.7 with the engine cold.

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 & 2014 Bass Race 149.9 Champion!

 

2 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 Massive 15" subs and small power, http://www.stevemead...-bandpass-wall/


#24
extremeauto

extremeauto

    130db

  • Members

  • 487 posts
  • Gender:Male
  • Location:Monmouth il
  • Interests:cars car audio

Holds solid 14.5 with the engine hot, 14.6-14.7 with the engine cold.

check the power lead on the alt mine did the same thing but was melted ...when cold i would get ok voltage at normal temps i would get 12.5-13 volts no load my power lead was not making a great connection after it melted the thermal gard on the power lead of the alt
1995 Honda passport 3.2 4x4 Frankenstein on a budget ballistics sound deader (roof only so far) kenwood mp3 usb audio control 3 (upgrading) hifonics mx-3 3 sets of massive px5 5.25s 3 sets of massive tweets phonix gold 5.25 componets x2 massive nx4 nano 200x4 mids sony xplod 600x4 watt high's 2 Fi bl fully loaded box walled @31ish hz 13.2 cube box/wall massive DB8000 Excessive amaperge 250 amp alt wir extrnl regulator daul runs of xs power xpflex 0 gauge big 3 raptor 0 gauge power/ground wire full run suriken 45 amp hour x3 shriken bt-120 batts,interstate 1100CA semi batt scytek galaxy 2way alarm still upgradeing!



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users