Jump to content

Mechman Alternators
Welcome to SMD Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Something wrong with my Mechman?


79 replies to this topic

#21
extremeauto

extremeauto

    130db

  • Members

  • 487 posts
  • Gender:Male
  • Location:Monmouth il
  • Interests:cars car audio



I'm not gonna gang up on Mechman as my issues are really at idle, on my low power at 1k rpm and up I'm getting 14.6-14.9v ... Soon as I get to 700 on dash it drops to 13.6-12.7-12.3-12.2 .... Apparently my car sucks???

hmmm sound like my 200 amp universal mechman i had to send back and PAY to have fixed...

Were you the original owner?

If not you are not covered under warranty.

When I had an issue with mine they fixed it within 1 business day and was all covered under warranty

bought it brand new from matt @ mechamn was told i used the wrong ring termal on my power lead from the alt.... :bull: i paid for the repair and bought a 0 gauge power wire from them ...hopefully it was my fault ora fluke and i will have no more issues ...sad thing is my stock 70 amp alt ahs took its place for the last 2 month and is holding like a champ.. the mechman lasted 2 months:pardon:

Edited by extremeauto, 10 December 2011 - 11:28 PM.

1995 Honda passport 3.2 4x4 Frankenstein on a budget ballistics sound deader (roof only so far) kenwood mp3 usb audio control 3 (upgrading) hifonics mx-3 3 sets of massive px5 5.25s 3 sets of massive tweets phonix gold 5.25 componets x2 massive nx4 nano 200x4 mids sony xplod 600x4 watt high's 2 Fi bl fully loaded box walled @31ish hz 13.2 cube box/wall massive DB8000 Excessive amaperge 250 amp alt wir extrnl regulator daul runs of xs power xpflex 0 gauge big 3 raptor 0 gauge power/ground wire full run suriken 45 amp hour x3 shriken bt-120 batts,interstate 1100CA semi batt scytek galaxy 2way alarm still upgradeing!

#22
CJ18

CJ18

    System of the Month Winner November '11

  • Authorized Member Seller


  • 12,731 posts
  • Gender:Male
  • Location:Florida
All of mine have always reached full power at about 2000-2500rpm. Does your voltage fluctuate while at idle or does it hold solid at 14.5?

SMD Authorized Member Seller

SMD Super Seller

 

Authorized Online Dealer

DC Audio

Sky High Car Audio

XS Power

CE Auto Electric Supply

SMD

D'Amore Engineering

 

www.droppinhzcaraudio.com

email- [email protected]

 

codysignature_zps808a7901.jpg

 


#23
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D
Holds solid 14.5 with the engine hot, 14.6-14.7 with the engine cold.

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#24
extremeauto

extremeauto

    130db

  • Members

  • 487 posts
  • Gender:Male
  • Location:Monmouth il
  • Interests:cars car audio

Holds solid 14.5 with the engine hot, 14.6-14.7 with the engine cold.

check the power lead on the alt mine did the same thing but was melted ...when cold i would get ok voltage at normal temps i would get 12.5-13 volts no load my power lead was not making a great connection after it melted the thermal gard on the power lead of the alt
1995 Honda passport 3.2 4x4 Frankenstein on a budget ballistics sound deader (roof only so far) kenwood mp3 usb audio control 3 (upgrading) hifonics mx-3 3 sets of massive px5 5.25s 3 sets of massive tweets phonix gold 5.25 componets x2 massive nx4 nano 200x4 mids sony xplod 600x4 watt high's 2 Fi bl fully loaded box walled @31ish hz 13.2 cube box/wall massive DB8000 Excessive amaperge 250 amp alt wir extrnl regulator daul runs of xs power xpflex 0 gauge big 3 raptor 0 gauge power/ground wire full run suriken 45 amp hour x3 shriken bt-120 batts,interstate 1100CA semi batt scytek galaxy 2way alarm still upgradeing!

#25
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D
Tomorrow iīm gonna check everything on my electrical i guess, suck ass because i wanted to do the complete 1500 watts amplifier challenge :(

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#26
siccostyle

siccostyle

    member

  • Members

  • 1,984 posts
  • Gender:Male
  • Location:born n raised in tha 805
  • Interests:Sub Sonic Addiction
That sucks homie hope that you can get things straightened out.

[color=#a9a9a9;][font="'comic sans ms';"]01 2dr Exploder[/color][/font]
Build log
[color=#a9a9a9;][font="'comic sans ms';"]2 18" DC Level 6's (M3's)
DC 10k
5 XS d3100's, DC 390 alt
100' shok ofc cable[/color]
[/font]

 

[color=#a9a9a9;][font="'comic sans ms';"] [/color][/font]
[color=#FFFFFF;]Team Shok[/color]
[color=#ffffff;]TEAM SUB SONIC ADDICTION[/color]


#27
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D

That sucks homie hope that you can get things straightened out.


Thanks david, weīll see what happens, we spoke about this like a month ago and i we both knew there was something weird going on, but damn, i didnīt expect such a large voltage drop using that "proper" electrical with barely 1600 watts :S

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#28
siccostyle

siccostyle

    member

  • Members

  • 1,984 posts
  • Gender:Male
  • Location:born n raised in tha 805
  • Interests:Sub Sonic Addiction
Yeah I didn't realize that it was that bad of a voltage drop either. With the amount of power that your using you should be rock solid I would think. Hopefully its just a faulty alt which can happen with a big company like Mechman. Not every alt is going to be perfect and if you got a bad one I would think that Mechman would take care of you. I have never used there products myself but I have heard good things about their customer service. Good luck homie I hope things get straightened out for you. :drinks:

[color=#a9a9a9;][font="'comic sans ms';"]01 2dr Exploder[/color][/font]
Build log
[color=#a9a9a9;][font="'comic sans ms';"]2 18" DC Level 6's (M3's)
DC 10k
5 XS d3100's, DC 390 alt
100' shok ofc cable[/color]
[/font]

 

[color=#a9a9a9;][font="'comic sans ms';"] [/color][/font]
[color=#FFFFFF;]Team Shok[/color]
[color=#ffffff;]TEAM SUB SONIC ADDICTION[/color]


#29
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D
Hey guys, some news over here, i burped the car using a single DD m2a (1600 watts amplifier) wired at 0.5 ohms and got this results:

Idle: 14.6 v dropping to 11.1v
3K RPM: 14.7v dropping to 11.5v
5K RPM: 14.8v dropping to 11.8v

Said that, i checked all my wires and connections and found something that might cause any problems, but i prefer to ask you guys first since you know much more than myself about electricals, iīm not afraid to say that iīm good at few things and a noob on some other, my wire from the alternator to the positive on the battery itīs a 0 gauge, when we built the car we used an ANL 200 amps fuse on that line, few months later i changed the alternator and i completly forgot i had a 200 amps fuse on that line, said that, do you guys think thatīs what itīs causing the problem? maybe the alternator output is getting "chocked" because iīm using that small fuse? once again, i didnīt remember i was using that fuse in there and i have no clue if a 200 amps fuse is cutting my alternatorīs output, i dunno much about electricals lol, any inputs????

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#30
extremeauto

extremeauto

    130db

  • Members

  • 487 posts
  • Gender:Male
  • Location:Monmouth il
  • Interests:cars car audio
the smaller fuse would restrict it but i dont think that is the issue...change it and see and have u checked the alt postive wire yet? do u have a voltage reglater?is it turned up? ur getting voltage drop like the alt is barely even sending out put..
1995 Honda passport 3.2 4x4 Frankenstein on a budget ballistics sound deader (roof only so far) kenwood mp3 usb audio control 3 (upgrading) hifonics mx-3 3 sets of massive px5 5.25s 3 sets of massive tweets phonix gold 5.25 componets x2 massive nx4 nano 200x4 mids sony xplod 600x4 watt high's 2 Fi bl fully loaded box walled @31ish hz 13.2 cube box/wall massive DB8000 Excessive amaperge 250 amp alt wir extrnl regulator daul runs of xs power xpflex 0 gauge big 3 raptor 0 gauge power/ground wire full run suriken 45 amp hour x3 shriken bt-120 batts,interstate 1100CA semi batt scytek galaxy 2way alarm still upgradeing!

#31
NightmareImpala

NightmareImpala

    130db

  • Members
  • 309 posts
  • Gender:Male
  • Location:West seneca, ny
I am having same issue with my mechman 270 alt. Getting voltage drop to low 11 volt range. Running a dc 3k and 2 xs power d3400 batts. Curious to see what matt says. im prob gonna give them a call.
TEAM DISTANT THUNDER

#32
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D

the smaller fuse would restrict it but i dont think that is the issue...change it and see and have u checked the alt postive wire yet? do u have a voltage reglater?is it turned up? ur getting voltage drop like the alt is barely even sending out put..


That fuse was on the alt positive wire to the battery, tomorrow iīm gonna change it for a 300 amps fuse or just run it directly without any fuse, i donīt have a voltage regulator, and i how can i know if the alternator is barely sending out put? i just donīt know what the hell is going know actually, i just know i have an aternator that costed me 500$ , 4 runs of 0 gauge, a big ass battery in perfect condition and a small amplifier :S

I am having same issue with my mechman 270 alt. Getting voltage drop to low 11 volt range. Running a dc 3k and 2 xs power d3400 batts. Curious to see what matt says. im prob gonna give them a call.


Damn!! since you installed it? iīm getting frustrated already :S

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#33
Miguels

Miguels

    Not So Loud

  • SMD Bronze Member

  • 5,921 posts
  • Gender:Male
  • Location:Los Angeles
do you have an amparage meter? try using one and see what is the output on the alt. i dont even get that bad of a voltage from my stock alt running a brz2400, i do have 2 kinetik hc2400 though


edit:i would get 10.8 volts on my other truck with a stock 40a alt and would drop to 9v with everything on and making everything shut off.

Edited by Miguels, 11 December 2011 - 10:22 PM.


#34
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D
As i always says, there are a few things that i donīt have a clue about car audio, iīm kind of a noob about electricals, first HO alternator iīve ever owned is this mechman and iīm very frustated right now, how the hell can i check how many amps is my alternator really sending??? i do have a clamp meter...

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#35
crunkjuice1

crunkjuice1

    145db

  • Members

  • 1,272 posts
  • Gender:Male
  • Location:San Antonio Texas
  • Interests:Car audio, xbox live, PSN and home theater
When I got mine last year I asked matt about fusing the line from alt to battery and he said not to do it because if something were to go wrong something would actually mess up in the alt. Call and ask and double check that.

Posted Image

 

Posted Image


#36
Miguels

Miguels

    Not So Loud

  • SMD Bronze Member

  • 5,921 posts
  • Gender:Male
  • Location:Los Angeles
To test the alternator output use a current clamp meter around the alternator + lead.
Turn on whatever your load is and read the output in amps.

#37
Azagtoth502

Azagtoth502

    666 db

  • Members

  • 4,478 posts
  • Gender:Not Telling

As i always says, there are a few things that i donīt have a clue about car audio, iīm kind of a noob about electricals, first HO alternator iīve ever owned is this mechman and iīm very frustated right now, how the hell can i check how many amps is my alternator really sending??? i do have a clamp meter...


http://audioforum.te...22;t=003982;p=0

#38
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D

When I got mine last year I asked matt about fusing the line from alt to battery and he said not to do it because if something were to go wrong something would actually mess up in the alt. Call and ask and double check that.


For real??? a fuse can hurt an alternator?? if that true, he never told me anything, as i said before, my alternator didnīt even come on a box with at least a mechman logo, no manuals, no nothing...

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#39
fecupe2001

fecupe2001

    Drunk SPL

  • Members

  • 5,578 posts
  • Gender:Male
  • Location:Panama City, Panama
  • Interests:Car audio and hookers :D


As i always says, there are a few things that i donīt have a clue about car audio, iīm kind of a noob about electricals, first HO alternator iīve ever owned is this mechman and iīm very frustated right now, how the hell can i check how many amps is my alternator really sending??? i do have a clamp meter...


http://audioforum.te...22;t=003982;p=0


I might be dumb or blind haha, did i miss how to test the amperage the alt makes? i didnīt see that anywhere, and remember that iīm from Panama, no autozone or anything like that around here lol

I´m the SPL Gains topic creator!! wanna get louder?? check this: SPL Gains. Panamenian 2009 & 2010 Bass Race 149.9 Champ First Venezuelan Bass Race competitor and champion!! Loudforce Distributor for Latin America.

 

2 Loudforce 15" subs and a 2K wired at 1 ohm,  http://www.stevemead...ideo-on-page-3/

 

8 loudforce 15" subs and small power, http://www.stevemead...-bandpass-wall/


#40
Miguels

Miguels

    Not So Loud

  • SMD Bronze Member

  • 5,921 posts
  • Gender:Male
  • Location:Los Angeles
just clamp it and put a load on the alt (turn everything on and play at full tilt)and you will see the amp go up, and no the fuse cant hurt the alt. its the other way around if you dont have it and you have a short somewhere it could mess up the alt.



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users