Jump to content
 
 

Sign in to follow this  
FiNaLaLmAsY

2 RE XXX 12 Getting HOT!

Recommended Posts

Hey guys, Happy 4th July!

i finally got a Box built to Spec for the 2 RE XXX 12's from Greg at RE.

1.7cu a side Tuned at 30Hz By time Displacement..

IMAG0255.jpg

Let me tell you it sounds AMAZING! and plays so loud it takes the air from your lounges for being a trunk build!

but..after about 1min of playing on my crescendo audio BC3500 for about 1min or so they get VERY HOT and you can smell them.. like a burning smell and been like this for 2 weeks.. i havent even really played them but a couple burps just to mess around with friends but pisses me off these should be able to play more then a minute.. i took my amp to my Amp guy and tested it and its very clean power and good power going to the subs..

subsonic set about 25-28hz btw.

bass boost "off"

i also have the front windows down which plays WAYYYY Louder and gets air to the subs..

Any ideas..Please and thank you!


02 Nissan Sentra

4 DD 3500g 10's

Crescendo Audio 3500 @ .5ohms

Soundstream EGA4220

Fronts German Mestreo 6.5 Component Set 110Rms

Rears RE XXX 6.5 Component Set 2ohms 220RMS

1 Dyralast Gold 1000Amp Battery

1 Vmax 2000amp Battery

DC Power Inc 270XP Amp Alternator

BIG 3 Upgraded

All 1/0AWG Setup

8 1/0 Awg Runs

Share this post


Link to post
Share on other sites

Song clipping, Amp clipping are some reasons it could get hot. My Re SXX were stinking up my car forever!! but after about 4-5 months of playing it has finally stopped. Soon as you smell it turn it off/down.

Share this post


Link to post
Share on other sites

let me put it this way barley turning up the amp it does it..about 2k coming from the amp and getting 1k a speaker it should not be clipping im also talking about low volumes.. i personally think there is something wrong with the speakers..


02 Nissan Sentra

4 DD 3500g 10's

Crescendo Audio 3500 @ .5ohms

Soundstream EGA4220

Fronts German Mestreo 6.5 Component Set 110Rms

Rears RE XXX 6.5 Component Set 2ohms 220RMS

1 Dyralast Gold 1000Amp Battery

1 Vmax 2000amp Battery

DC Power Inc 270XP Amp Alternator

BIG 3 Upgraded

All 1/0AWG Setup

8 1/0 Awg Runs

Share this post


Link to post
Share on other sites

Song clipping, Amp clipping are some reasons it could get hot. My Re SXX were stinking up my car forever!! but after about 4-5 months of playing it has finally stopped. Soon as you smell it turn it off/down.

It's best to set it up right so you never get them hot like that to begin with. Consider the benifit of the SMD Distrotion Detector. Much cheaper then buying nice subs, running them hot, then having to replace/recone them every 5-6 months.

http://wccaraudio.com/smd-distortion-detector-dd-1.html


CURRENT SYSTEM:

  • Alternator:
    1. Stock alt on mids/highs
    2. Isolated DC Power 270 SP - Charging @ 16.8v
  • Batteries: (2) XS D1400s
  • Power Cable: Double Runs of 1/0 KNU Kolossus Fleks
  • Headunit: 80-PRS
  • Sub Amp: DC 5.0k
  • Subwoofers: 2 RE MT 15s /PSI dual .7ohm recones
  • Subwoofer Enclosure: 9.1cubes @ 32hz - brutal.
  • Mids & Highs Amp: CT125.4
  • Active Components:
    • Mids RE XXX 6.5c
    • Highs - 3 RE XXX tweeters per side(A pillar)
  • Noise Control: Damplifier Pro all over the cab.

Build Log

If you do business with me please leave feedback here: FEEDBACK THREAD

 
Highest Legal Score: 151.0 db
Highest Musical 30 Second Average: 151.6 db

Share this post


Link to post
Share on other sites

lets put it this way i had 2 soundstream SPLXHX on the same amp same gains and never had this issue and they are only rated at 1000RMS..lol both speakers RE and Soundstream Dual 2ohm VC

Edited by FiNaLaLmAsY

02 Nissan Sentra

4 DD 3500g 10's

Crescendo Audio 3500 @ .5ohms

Soundstream EGA4220

Fronts German Mestreo 6.5 Component Set 110Rms

Rears RE XXX 6.5 Component Set 2ohms 220RMS

1 Dyralast Gold 1000Amp Battery

1 Vmax 2000amp Battery

DC Power Inc 270XP Amp Alternator

BIG 3 Upgraded

All 1/0AWG Setup

8 1/0 Awg Runs

Share this post


Link to post
Share on other sites

lets put it this way i had 2 soundstream SPLXHX on the same amp same gains and never had this issue and they are only rated at 1000RMS..lol both speakers RE and Soundstream Dual 2ohm VC

It just seems odd that you would get 2 bad RE XXX subs at the same time. How are your subz wired?


CURRENT SYSTEM:

  • Alternator:
    1. Stock alt on mids/highs
    2. Isolated DC Power 270 SP - Charging @ 16.8v
  • Batteries: (2) XS D1400s
  • Power Cable: Double Runs of 1/0 KNU Kolossus Fleks
  • Headunit: 80-PRS
  • Sub Amp: DC 5.0k
  • Subwoofers: 2 RE MT 15s /PSI dual .7ohm recones
  • Subwoofer Enclosure: 9.1cubes @ 32hz - brutal.
  • Mids & Highs Amp: CT125.4
  • Active Components:
    • Mids RE XXX 6.5c
    • Highs - 3 RE XXX tweeters per side(A pillar)
  • Noise Control: Damplifier Pro all over the cab.

Build Log

If you do business with me please leave feedback here: FEEDBACK THREAD

 
Highest Legal Score: 151.0 db
Highest Musical 30 Second Average: 151.6 db

Share this post


Link to post
Share on other sites

did you check the setup with an oscope or a dd-1?

not just the amp...the whole setup

Share this post


Link to post
Share on other sites

each speaker has 8awg wire wired in parallel to the amp the amp believe it or not only sees.. .7ohms since ive owned the speakers


02 Nissan Sentra

4 DD 3500g 10's

Crescendo Audio 3500 @ .5ohms

Soundstream EGA4220

Fronts German Mestreo 6.5 Component Set 110Rms

Rears RE XXX 6.5 Component Set 2ohms 220RMS

1 Dyralast Gold 1000Amp Battery

1 Vmax 2000amp Battery

DC Power Inc 270XP Amp Alternator

BIG 3 Upgraded

All 1/0AWG Setup

8 1/0 Awg Runs

Share this post


Link to post
Share on other sites

my buddy jus picked up a used second xxx for his truck and we threw it in the box he had his other one in and it was hooked up to 1 of the new autotek mm4000.1 adjustments turned to high hell(he's getting it reconed anyway) and we were beating the hell out of it and it was stinking for a few mins and then it jus stopped smelling and its never smelled since dont no why it stopped and the sub was fine

Edited by 89boxchevy

89 Chevy Caprice (is under construction)

dual alts

4/0 welding cable for wire

red top under hood 3 yellow tops behind the front seat ( who needs a back seat anyways lol)

big 3 of course

Eclipse 3000

interiors are getting rebuilt now

2 crescendo bc2000

2 shocker sig 12s

rebuild pics

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...

SMD Chat Room

SMD Chat Room

Please enter your display name