Jump to content

Things that piss you off (anything)


Recommended Posts

You got a Grand Prix right bcp? Back flush the heater core I had to on my Grand Prix too. That won't be your check engine light but should give ur heat back.

Ya it a grand prix, I did my water pump and thermostat about 40k ago and did a total system flush twice because of how fucked the water pump was. I talked to my mechanic he said it could just be how cold it's been, plus I've been driving at night too. My CEL isn't on know it only was for like two starts after the wife like half started it or something.

Heating core, thermostat, idk wtf it might be but my heat has only been lukewarm in my car the last few days. I can't afford to fix it whatever it might be. Fucking sucks big time. I guess I'll be bundling up more until spring

Check and see if the coolant is full, I know it sounds dumb but I see it all the time.
I'll double check it was ok a few weeks ago before it got frigid down here, but shit happens you know

Well coolant was a little low but it was still in the reservoir. Next step I'll try to back flush the core. Also I noticed that it will warm up at idle but at highway speed the heat and engine temp both lower. My engine temp is only at normal when idle, not driving

"The strongest reason for people to retain the right to keep and bear arms is, as a last resort, to protect themselves against tyranny in government." -- (Thomas Jefferson)

Link to comment
Share on other sites

Warm at idle and cold going down the road? I bought a truck one time that did that. The thermostat was in backwards.

91 C350 Centurion conversion ( Four Door One Ton Bronco)

250A Alternator (Second Alternator Coming Soon)

G65 AGM Up Front  / Two G31 AGM in Back

Pioneer 80PRS

CT Sounds AT125.2 / CT Sounds 6.5 Strato Pro component Front Stage

CT Sounds AT125.2 / Lanzar Pro 8" coax w/compression horn tweeter Rear Fill

FSD 5000D 1/2 ohm (SoundQubed 7k Coming Soon)

Two HDS315 Four Qubes Each 34hz (Two HDC3.118 and New Box Coming Soon)

Link to comment
Share on other sites

Warm at idle and cold going down the road? I bought a truck one time that did that. The thermostat was in backwards.

It was fine last winter so I doubt it's that lol. I'm going to back flush the core as my next step

"The strongest reason for people to retain the right to keep and bear arms is, as a last resort, to protect themselves against tyranny in government." -- (Thomas Jefferson)

Link to comment
Share on other sites

might have to clean my maf. she sending me rich codes and maf out of range codes

so i think atm

Edited by deathcards

skar sk2500.1
0 gauge power and ground kunukonceptz
alpine HU
vxi65 components on BA gt-275
new build log -> http://www.stevemeadedesigns.com/board/topic/150642-project-d-kon-deathcards-build-log/#entry2148821
2 x-15 sundowns

singer alt, odyssey bat, and maxwell ultra caps

Link to comment
Share on other sites

You got a Grand Prix right bcp? Back flush the heater core I had to on my Grand Prix too. That won't be your check engine light but should give ur heat back.

Ya it a grand prix, I did my water pump and thermostat about 40k ago and did a total system flush twice because of how fucked the water pump was. I talked to my mechanic he said it could just be how cold it's been, plus I've been driving at night too. My CEL isn't on know it only was for like two starts after the wife like half started it or something.

Heating core, thermostat, idk wtf it might be but my heat has only been lukewarm in my car the last few days. I can't afford to fix it whatever it might be. Fucking sucks big time. I guess I'll be bundling up more until spring

Check and see if the coolant is full, I know it sounds dumb but I see it all the time.
I'll double check it was ok a few weeks ago before it got frigid down here, but shit happens you know

Well coolant was a little low but it was still in the reservoir. Next step I'll try to back flush the core. Also I noticed that it will warm up at idle but at highway speed the heat and engine temp both lower. My engine temp is only at normal when idle, not driving

Sounds to me like your thermostat is stuck open.

2007 Pacifica
Rebuild. Less quiet. Still not loud.

Link to comment
Share on other sites

Heating core, thermostat, idk wtf it might be but my heat has only been lukewarm in my car the last few days. I can't afford to fix it whatever it might be. Fucking sucks big time. I guess I'll be bundling up more until spring

. Your intake is probably leaking coolant witch they all do on that motor , so you have air in the coolant hoses causing no heat until you bring up rpm's to make the flow faster. Keep topping off your coolant until u fix it also could be the thermostat grab your lower hose when the car is hot if it's not hot your thermostat could be stuck open

2022 Ford Maverick on 22’s                                                                                                                                          Skar SK1500.1 on 4 Skar VD-8’s                                                                                                                       Mids Sundown Super tweeters, Skar TX 6.5 components on Skar SKM400.4                                                 LC2 for audio control  , XS Power D680 XS Series Extra Battery 

Link to comment
Share on other sites

it's 38° with 20+mph wind, we're not supposed to have this shit down here

IMG_0138_zpsyzr9c0js.jpg. I see your warm 38 and will take it 1 fucking degree here and windchill gonna be -20 let's just say it will be awhile before my balls drop back down

2022 Ford Maverick on 22’s                                                                                                                                          Skar SK1500.1 on 4 Skar VD-8’s                                                                                                                       Mids Sundown Super tweeters, Skar TX 6.5 components on Skar SKM400.4                                                 LC2 for audio control  , XS Power D680 XS Series Extra Battery 

Link to comment
Share on other sites

Real temp here in southern MN is -28. Windchill was at -49 early this morning

  • Like (+1 Rep) 2

2003 GMC Yukon Denali

Alpine CDA 117

Redoing Mids/Highs

4 Runs of 1/0 Knukonceptz 2+, 2-

4 Deka 9A31's in back (Stock underhood) 250 amp Alt.

AQ20K

2 18" Crossfire XS V.2's 12 cubes 33hz 149sq inches of port!

Link to comment
Share on other sites

Looked at the few bad reviews on Fi's FB page...

Everybody who posted them looks like a faggot ass bitch (through judging of their page content of course) or obviously had no fucking clue how to install a system and shouldn't be messing with anything close to the quality of Fi. One of them even has his car with a Fi decal on his back windshield as his cover pic rofl. Like, the fuck?

Oh well.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 51 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...