Jump to content

lvl 3 15


Recommended Posts

  • 4 weeks later...

Hey CJ, I built a box for the sub that was 3.56cuft with 49 inches of port tuned to 35hz and It seems like the output is kind of missing. Is there anything I can do to get better output, like a different box or something? Because I feel like the sub should be much much louder then what it is right now.

Thanks,

Brennan.

BABYJUICE

Link to comment
Share on other sites

THat would be the first place I would start. Without seeing/hearing for myself, it is very hard to diagnose and fix anything, but the amplifier is where I would start.

Maybe try dropping your amp down to .5 ohm and just be careful with the gain first and see how it likes it. The box specs you posted look perfectly fine. If it doesnt sound right, the issue has to be coming from somewhere in line with the settings or amplifier itself.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 78 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...