Jump to content

Recommended Posts

It was awesome to see Ren and the DC Ride today, Been a little while, Making plans to have it at a show soon

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Kraken
      So I'm trying to design a box for my 2 zv3 12's, i have installed 2 bucket seats in the rear of my 02 chevy pickup, and things have changed a ton in that truck since i last posted here. I plan on doing 2 zv3's in a ported box in between the 2 seats, almost like a tall center console. i found a 3D model of a zv3 12 on a different fourm, but i cant get the person to respond with a link to a download. Im just trying to get an accurate look of the box, and also having a model of the sub would be cool
    • By dylan33
      Hey so I've only been having this issue since I switched out my subs and amplifier from a kenwood excelon set up to the rockford amp and subs. Whats happening is the amp BANGS all day no matter what at the lows but the moment it gets to a higher frequency seems like a punchier frequency (I wish i Knew what frequency it was but i Just know its not the low end probably way closer to 80hz), it goes into PROTECTION mode. I thought at first it wasn't getting enough voltage and my battery tested at 50% cause i do have a battery tester at our shop, so I changed my battery today and I'm still having the same issue. I know its not my wiring because i had no problems with others amps and subs ect. Rockfords support tech keeps saying its clipping at this certain frequency, which I'm not eliminating yet, but the thing is I have my gain set to just under 7, and it was still doing the same thing even when i had the gain set to under 5. and it doesnt hit nearly as hard as it should be unless i turn the gain closer to over half. I just want to know what i can eliminate and what i should try if you guys are familiar with this issue. If my amp is clipping why wouldnt it be clipping on the lows and only does it on the highs? Another thing is it hardly does it when I'm parked, mailny does it when I'm driving which is really irritating because I want it when I'm driving I could care less about being parked as this is just my daily driver. Any advice would help. The other 3 installers at my shop said battery and rockford only said clipping.. I also tested my alternator with our snap on tester and it also tested good. All that rockford said was too turn down the gain but I know those subs can handle what I'm giving them at least I would think.. Radio is outputting full 5.0 volts
      Gain = ~60%
      Lpf = ~25%
      Punch EQ = 0
      subsonic filter = 50%
      2005 Dodge Stratus 
      2 Rockford Fosgate P3D412s with RF R1200 Prime Amplifier
      4 gauge rockford power and ground wire 12 gauge rf speaker wire down to 1 ohm
      Kenwood Exceleon kdc x501 subwoofer level set to +10 sub lpf set to through 
    • By crazydoublekick
      Hey, all!
      This is my baby.  It's a 2003 Mitsubishi Montero that I drove in high school; I recently bought it back from my folks for a couple grand, and its whole purpose is to be destroyed with bass.  She's in decent shape for 140k miles.  A few years ago, I had a c-pillar wall in this thing with 2 Fi BTL N2 18s on a n AQ3500.1 at .7.  It did 152s with garbage electrical, and was super fun.  I've always dreamed of walling this thing at the b pillar, so here we go.

      All I saw here was potential.  Time to rip all this shit out.
      The process has begun.

      Carpet cut, headliner removed, and roof braces foamed.  There's quite a decent amount of space in this bitch.
      Maaaany more pics to come.  Just gotta get them on Imgur.  Stay tuned!
    • By Bl800dy
      I recently bought a crescendo 3500 for my hd12s and noticed that the clipping light turns on at a certain volume I haven’t tuned my amps but I don’t notice or here and distortion I have it on my daily driver, i never really tuned any of my past systems yet never had a problem with distortion/clipping does it matter if I get a little clipping in my system?
    • By Rich Schenk
      Have a c-pillar slide in wall in my 00 mountaineer for 6 ascendant audio mayhem 12s and need to seal it off. Was told by some people spray foam in garbage bags around box. Question with this because it's right next to windows will regular and big gap foam potentially break a window or will I be fine with it against a window. (sorry never done this) also how should I mount false panels to roof, sides, etc? Any info or help on this would be greatly appreciated Ty.
  • Who's Online   16 Members, 1 Anonymous, 969 Guests (See full list)