Jump to content

Recommended Posts

I have a Rockford Fosgate T2 D4 12" and it gets extremely hot when I play music. If im not mistaken its the voice coil heating up and i can smell it. I went and had a 2nd battery install to help the heat from the cone but that didnt help. I was told that my main battery might be bad. i went and got it tested and the battery was good. i don't know what i need to do next. the sub is wired to 4ohms on a kicker zx1500.1. PLEASE HELP.

Edited by Alexander Fennell
Link to comment
Share on other sites

are u sure its 4 ohms? how is it wired can u draw a picture? what size and brand wire are you using

J. Jsig_253411.jpgMy CardomainFINISHED COBALT SS/SC DUAL ALTERNATOR PICS icon_nuts.gif

theres no such thing as too expensive when it comes to upgrades like that, because imo if you are gonna spend to upgrade then do it correctly rather then be a cheap ass ricer
Link to comment
Share on other sites

I had a t2 d2 15..I think its your gains..I had mine on a 1500w amp and when I was clipping the sub would get hot and smell stinky..with that sub it usually happens if you set ur gains by ear..or the box might not have enough clearance for correct venting ..that sub does have a large pole piece but the aluminum cone and dust cap also retains heat so thats all bad too..all I could suggest is set ur gains with a dd1 and get another sub because I blew mine luckily it had warranty I came out of pocket 80bucks for shipping and sold the new sub once I got it

You need trunk space to get groceries and shit...bitches love groceries

Link to comment
Share on other sites

Also with that sub if you're smelling it ..it's probably going to blow In a few months so start looking at subs to see what you really want out of a sub..and start saving the money to get it

You need trunk space to get groceries and shit...bitches love groceries

Link to comment
Share on other sites

I've ran a t2d412 clipping like crazy (bass boost, loudness, gain 1/2-3/4 up, full tilt stock electrical) and it took it for about 6months (t1500.1bdcp). No smell until it started smoking. Replaced under warranty (didn't have to pay shipping local dealer covered it)

ran that one for about 3months no chance of clipping (no boost, loudness, gain all the way down not full tilt stock electrical). Speaker took the clean signal like a champ!

had a t2d415 on the same t1500.1bdcp for about a month or 2. No clipping deck checked with dd1 62/62 full tilt gain all the way down playing decaf a good amount of time. Took that like a champ. Still have the sub and coil looks brand new suspension still feels stiff as new.

point in making, those subs will handle 1500 clean. No problem at all.

also why would you think the added battery would help the sub handle more then rated power? Sure bad voltage drop can induce clipping but the biggest most common issue is the users choice of setting. Gain, bass boost, or any option like it will/can create clipping

t1500bdcp

2 t2d4 15"

1 t600.4

1 t400.2

1 set p1 tweets

singer alt, tons of wiring, smd vm-1, 80prs, back seat delete, still in the works, aiming for a 145-147 with the ability to play 25hz up to 50hz.

Link to comment
Share on other sites

I had my t2 15 on 2100 probably clipping and it took it just fine until the cool started rubbing cause I bottomed the fuck out of it lol box was 4.5cbft and the sub took that box just fine for probably 6 months, then I put it on a dc 3.5k at 1 ohm probably clipping in the same box with a coil rubbing on a stock electrical and it took 20hz test tones with a car battery placed on top of it to blow it. Maybe mine was a freak of nature but that bitch was tough

2006 Ford Explorer

2 Team AA/Sundown 15s

6th order

Ct Sounds 7k

4 PRV Mr500 8s

Rockford p1000-2

Team Subsonic Lows

Link to comment
Share on other sites

They are some mean subs.

another member gave me some advice and thinks all break a 150 with 2 of them on 3k. We will see what happens once I get back on my own feet. Hopefully late this summer I'll have it going.

t1500bdcp

2 t2d4 15"

1 t600.4

1 t400.2

1 set p1 tweets

singer alt, tons of wiring, smd vm-1, 80prs, back seat delete, still in the works, aiming for a 145-147 with the ability to play 25hz up to 50hz.

Link to comment
Share on other sites

 Share

×
×
  • Create New...