Jump to content
Mechman Alternators

VOLTAGE problem...yet again. HELP! Mechman? Anyone?


Recommended Posts

I chose to post here because Mechman is closed for the day and I wanted some outside advise

I am going to explain my problem in the most exact way I can and list every single thing I can so there are no silly questions.

I previously had low voltage issues with a install that I had done and couldn't narrow it down because the install was crap. Since then I have had the entire stereo re-done with a PREMIUM install.

Here are the facts:

2012 Toyota Camry

240A Mechman Alternator (purchased about a year ago but only been in vehicle 6-8 months)

XS Power D3400 under the hood.

Big 3 upgrade with premium Sky High 1/0 wire. All wires are soldered and all grounds are proper and clean.

Amps:

Rockford Fosgate 1500 BDCP (bass)

Rockford Fosgate T800-4ad (mids & highs)

Subs:

DC Audio Level 3 10's (2)

Rear battery:

XS Power D925

Processor:

Audison Bit Ten

1/0 wire ran from front battery to rear. Amps are powered from the rear battery.

SMD VM-1 tied into rear battery

I am only capable of running 2200 rms (at 14.4v). I am having a massive issue with voltage. 13.1 at idle with HUGE dips all the way down to mid 11's on some serious bass notes. I just don't freaking understand!! I have premium equipment with more alternator and battery power that I should need for such a small stereo and still have voltage issues. I had higher voltage before the stereo!. Before install I had 13.8-14.0 (never had any higher. Even when new).

PLEASE HELP!!

My stereo is suffering because I can't get NORMAL voltage. That alternator is barely charging the batteries at all. I EVEN GET 13.0 with engine OFF!! I am at my end with this damn stereo.

WHAT????????

Link to comment
Share on other sites

  • 2 weeks later...

when the car is on does the voltage go up at all when you rev the motor?? does it go past 13.1?? if not i think the alt may not even be on and working at all. if your voltage is 13 with the car off i'm pretty sure your'e just running the system on battery power alone, which would explain the dips into the 11 volt range. just my thought.

Link to comment
Share on other sites

Its your car thank toyota

THERE IS NO BUILD LOG!

1998 Chevy Silverado ext cab

Alpine CDA-9887

4 Team Fi 15s

2 Ampere Audio TFE 8.0

2 Ampere Audio 150.4

3 Digital Designs CS6.5 component sets

Dual Mechman 370XP Elite alternators inbound!

8 XS Power d3400

6 XS power d680

Second Skin

Stinger

Tsunami Wiring

Sky High

A Real Voltmeter not a piece of shit stinger.

Link to comment
Share on other sites

Its your car thank toyota

i agree....

i direct everyone that asks me for a alt, with any type of newer, gas sippin, type car, to mechman and dc....

dont wanna touch it...

that said? ill bet the oem alt would be just fine with that load he has.... just saying...

edit- what the op may be failing to mention? is that mechman probabaly told him about having to external reg, and it may throw a light, or code, and op said no.

Or, mechman is just waiting to say this IF this issue arrised...

Edited by KyLar96
Link to comment
Share on other sites

well theres always external regulation. but other than that, you are limited to that pcm toyota regulation.

Buyer/Seller Feedback Thread: http://www.stevemead...5015-bump4life/
MB C220 153 Trunk Car Build Log: http://www.stevemead...d/#entry1840136
MB C280 Ipad Dash SQ Build Log: http://www.stevemeadedesigns.com/board/topic/194484-bump4lifes-new-benz-tony-c-relay-kit-pictures-ce-electric-audison-front-stage-installed/
My SPL Log: http://www.stevemead...__fromsearch__1

BMW M340 xDrive

Stock, for now. Corner Load 10" maybe soon. But does 10s in the 1/4...
Best Scores out of a trunk
153.0 sealed legal full tilt clamped 5524 @ 42 hz
154+ windows down, 155+ kick

Link to comment
Share on other sites

You need to externally regulate it. Mechman will help you with that.

http://www.stevemeadedesigns.com/board/garage/vehicle/2438-jeep-commander/


th_140x100square.jpgMechman_140x100px.JPGDCHome.jpgI

image_url-76414-1423274612_thumb.jpgimage_url-76414-1423320284_thumb.jpg

Pioneer P99RS
Ampere 3800
2-Ampere 125/4
4-6.5 inch Hertz HSK XL Mids
4-8 inch JL Audio ZR Midwoofer

2-5.25 Satori Mids
2-Morel Tweeters, 2 Hertz Milles 3 inch on A pillars
2-Hertz Silk tweeters
DC Audio Level 5/12
Skyhigh Wire
Mechman 320
XS Power D3100

MO Funniest Thread of the Year 2013: http://www.stevemead...dy-being-a-pos/

Link to comment
Share on other sites

I bought the AVBM. It works so far but its built poorly. 1 wire came out of the plug as soon as I opened the package. The adjustment knob doesn't have a max setting. It just keeps on turning. I opened the module (voids warranty) and found a very simple design. 2 wires were even twisted together with no connector and any protection. Very poor craftsmanship and high profit margin. The wires were short and very small in diameter. The plug looks like it was made with a 3D printer. Since dealing with Mechman and their products, I will most likely not do anymore business with them. Their CS seems to be good and their sales staff is friendly but their products seem to be sub par. $179 for a AVBM that probably cost $20 to make. Not trying to bash Mechman, just giving my honest opinion.

Not getting optimum power from my alternator either. Yes, all my equipment is top notch so it's nothing other than the alternator itself.

Edited by hankfan79
Link to comment
Share on other sites

I bought the AVBM. It works so far but its built poorly. 1 wire came out of the plug as soon as I opened the package. The adjustment knob doesn't have a max setting. It just keeps on turning. I opened the module (voids warranty) and found a very simple design. 2 wires were even twisted together with no connector and any protection. Very poor craftsmanship and high profit margin. The wires were short and very small in diameter. The plug looks like it was made with a 3D printer. Since dealing with Mechman and their products, I will most likely not do anymore business with them. Their CS seems to be good and their sales staff is friendly but their products seem to be sub par. $179 for a AVBM that probably cost $20 to make. Not trying to bash Mechman, just giving my honest opinion.

Not getting optimum power from my alternator either. Yes, all my equipment is top notch so it's nothing other than the alternator itself.

since you already voided your warranty, care to open up and take a pic for us? lol. id be interested to see what they use.

Buyer/Seller Feedback Thread: http://www.stevemead...5015-bump4life/
MB C220 153 Trunk Car Build Log: http://www.stevemead...d/#entry1840136
MB C280 Ipad Dash SQ Build Log: http://www.stevemeadedesigns.com/board/topic/194484-bump4lifes-new-benz-tony-c-relay-kit-pictures-ce-electric-audison-front-stage-installed/
My SPL Log: http://www.stevemead...__fromsearch__1

BMW M340 xDrive

Stock, for now. Corner Load 10" maybe soon. But does 10s in the 1/4...
Best Scores out of a trunk
153.0 sealed legal full tilt clamped 5524 @ 42 hz
154+ windows down, 155+ kick

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 227 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...