Jump to content

T400-2 protect mode on one channel??


Recommended Posts

Got a used t400-2 have 4 alpine type r 6x8 4ohm. So I ran each set @ 2 ohm to each channel for 125 watts per 6x8. Left Chanel good, as soon as I hook up right channel it goes into protection. I even tried one single speaker in right channel and same thing. So I hooked up my old soundstream back up and everything was good . Power good, ground good, rca good. What's up with this amp??? Please help

Link to comment
Share on other sites

I would say the if the right ch wont run @ 4 ohm there is something wrong with the amp. Call RF Support and find out out about shipping and repairs cost. If its affordable then get it fixed, if not it will be a loss. Bummer, good amps with a ton of power.

Link to comment
Share on other sites

I fix amps, that amp is faulted, which the person who sold it to you might have not said something, could be a easy fix, open it up and check for a bad cap or mosfet, if its a mosfet the whole set would have to be replaced.

On 2/12/2017 at 6:59 PM, Michael Dean said:

Got a used t400-2 have 4 alpine type r 6x8 4ohm. So I ran each set @ 2 ohm to each channel for 125 watts per 6x8. Left Chanel good, as soon as I hook up right channel it goes into protection. I even tried one single speaker in right channel and same thing. So I hooked up my old soundstream back up and everything was good . Power good, ground good, rca good. What's up with this amp??? Please help

 

https://www.youtube.com/channel/UCWd1ShRnPbDG9ppgJKpumdA <---- show some love to my channel

Alpine MRH-F255 (old school), sub channel not used

Skar audio VX35-ST tweets in front  (invest in them they are worth it)

kicker zr120- nice underrated amp

Powerbass s1204 subwoofer in a 1.75 custom slot ported enclosure tuned to 30hz

Front doors Prv 6mb200s 8ohm

Alpine type-e 5.25 in dash took a shave and a hair cut.....- not in use

Rear doors alpine 6.5's model/series unknown but they are loud as hell

Factory alt

3.5 farad cap, does the job for now.

Deck is a pioneer mixtrax 700bt model

And my baby my Pioneer EQ-6500 i got for 10.00

Back-up amps- Ma Audio 598i, kicker zr120, my highly under rated JBL LC-A502 1xx watt amp...

On the side- Quantum tweets not yet installed

Link to comment
Share on other sites

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   2 Members, 0 Anonymous, 131 Guests (See full list)

×
×
  • Create New...