Jump to content

Recommended Posts

It has been nearly 3 years since I last posted on my Camaro build (wow time flies).  I decided in my boredom (eff you COVID) that I would make some changes and add some speakers and fix some things.  Sooooo, I decided to replace the rear speakers (I left the stock in place originally).  Since its just the rear deck for fill mostly, I decided on coaxial speakers and thought I try RF T1s.  I also will add some speakers to the side panels in the rear (same RF T1s).  So I bought 2 pair.  Time to get to work!

IMG_2365.jpg

IMG_2366.jpg

  • Like (+1 Rep) 3
Link to comment
Share on other sites

Fabbed up some speaker wires.  I originally tapped the rear speakers for speaker level input to a JL Audio Cleansweep.  So, all I have is rear speaker output, which normally is fine.  However, I cannot fade from to back doing it this way, nor can I hear the turn signal noise or use bluetooth for phone calls since they use the front speakers.

 

I will fix that using these speaker cables.  There are 3 pairs of wires in each, 1 pair will take audio back to the Cleansweep, the other 2 pair will send signal back to speakers.  Its clugey, but whatever.

IMG_2369.jpg

  • Like (+1 Rep) 1
Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...