Jump to content

Recommended Posts

  What’s crackin’ yo! Here is part one of what I have completed so far on this Yukon.

  The box is a GP high output XL glue-it-and-screw-it tuned to 31hz. Internal bracing was radiused and sanded before I  installed them. 
  The triple baffle was built in layers, countersunk, glued and screwed with Spax hardware.

   It was then fit up to the Evil 15’s and thru holes drilled to accommodate the 1/4-20 threaded inserts. This way the subs are bolted in. Baby Yoda added for force! 
  Any feedback or input  is welcome! :]

19D78511-60CB-4F89-8BFE-6550E25E9C6E.jpeg

8BB58BEA-5213-43EA-A907-184F76E60180.jpeg

CA77C0F3-3A2B-4E93-BB44-F3F2DA8F70A4.jpeg

1A8F4355-1A42-4083-A895-42163FA65933.jpeg

589BA779-B648-44A0-B705-2E6762E0396F.jpeg

8FF9143A-05A6-4378-93CC-F8A15E23F439.jpeg

797364ED-6265-4512-AA7C-ACC7C35DC5BB.jpeg

654AC85E-B602-4C34-932F-AAB4DFFE2078.jpeg

5F335A83-3027-4ADD-8207-1D0F3DA78912.jpeg

E9FB9168-AFBA-4D41-AADD-95289595DF3C.jpeg

28226D2E-68B0-4211-AA2D-0AAC81150C9A.jpeg

F8275D8C-4C88-4E06-A13C-B5BA7AD4B1F7.jpeg

66406688-02BF-4C59-A3B7-B34A611E1133.jpeg

6C9E6F45-BD01-4D81-A1DC-EBAD12346110.jpeg

  • Like (+1 Rep) 1
Link to comment
Share on other sites

2 hours ago, Dafaseles said:

Looks really good! How does it sound? Is that a HCCA? 👍 can barely find those anymore

   Thank you! It sounds great, I actually did a hair trick on myself XD (although it wasn’t real violent).

   The 5000.1 dv2 sounds clean, and yes they are getting scarce.

  • Like (+1 Rep) 1
Link to comment
Share on other sites

Those HCCA amps are rated at 12.3v I think, so at 14v, you're getting tons of power! I bet that thing sounds good as hell! 

2011 Chevy Silverado under construction

My build log here. Check it out! 

 

Link to comment
Share on other sites

13 minutes ago, Dafaseles said:

Those HCCA amps are rated at 12.3v I think, so at 14v, you're getting tons of power! I bet that thing sounds good as hell! 

Here is the Birth Sheet.

   My Underground Power 40ah lithium is normally sitting at 14.72v. You are correct, this will put out more power. 
   I have a AMM-1 but i either hooked it up wrong or there may be a defect. I wanted to use the AMM-1 to check dyno power. This way I can see what’s going on.

  In the image you can see the leads are not connected, but when I was testing…. I ran the positive lead to positive amp input and the same for the negative. Negative lead to amp ground on the amp input. 

BF698E13-3E8C-4972-A09C-C5915B180392.jpeg

931D3646-9DD4-48A1-AF35-44041E8AD7D9.jpeg

D1121E5F-B588-4DEB-A434-3EADA202FB20.jpeg

  • Like (+1 Rep) 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...