Jump to content

Amplifier shuts off


Recommended Posts

Hello guys I recently got a salt 8k I have 2 50ah B2 riot lithium batterys and a 320 amp alt, all ofc 1/0 power/ ground wire, big 3 is done. System was working beautifully then these little issues started happening, Id turn my car on the amp would be in protect so i took all the steps to get it out of protect, amp is back on and working next when at high volume the amp just shuts off I turn my deck off and power it back on and the amp is back on? I've checked all my wiring power,grounds fuses everything is tight and there's no exposed anything I cover my buss bars up with covers when everything is put back together still these issues keep going on? I'm totally confused on what it could be any help would be much appreciated my basshead brothers 20210903_222038.thumb.jpg.4d59501f07f5d185edc0c3bfc8b3cc3f.jpg20210906_201139.thumb.jpg.34983619d86b0d61448cb5f823b44c90.jpg20210906_201155.thumb.jpg.8501c2b43e9271e5295ec459ff3b8465.jpg20210906_201230.thumb.jpg.c2e944ddddfd930515f0fbfc1723a908.jpg

Edited by josephj86
Link to comment
Share on other sites

Do u have good grounds what ohms are u getting

06 Charger

Pioneer double din

Pioneer 6.5 and 6×9's

Knukoncept Krystal kable rca's

0 ga knukoncept kolossus wire 

Big 3 same wire ^ 1 run 

8g karma ss speaker wire

Sundown sia 3500d at 1ohm

2 Sundown U series 12's

Duralast platinum agm H7 (Main)

Xs power d3400

Trying to find a ho alt

 

 

Link to comment
Share on other sites

I didn't know B2 had their own line of lithium batteries....

Anyway, even though you should have enough electrical, I would have a voltage meter inside the vehicle with me, taking voltage at the amplifier, to make sure the voltage isn't the issue. 

Other than that, I would check every single connection for anything possibly being loose. Battery terminals, fuse bolts, connections into the amp, everything. 

Does this only happen with the 8k? Or does it happen to your 4 channel as well? 

What impedance are you running at and have you double checked it with a multimeter since you've been having the problem? 

  • Like (+1 Rep) 1

2011 Chevy Silverado under construction

My build log here. Check it out! 

 

Link to comment
Share on other sites

It only happens with the 8k my 4 ch stays on, my voltage doesn't drop much at full tilt drops to 13.4 and I have the amp is at 1ohm I've double check every connection coukd be ground location as well im going to try grounding in a different location. I think I know what it might be just from looking at the picture I noticed something that might be affecting the amp if you look at the right side of the trunk the strong arm drops pretty low I think that it could be pulling the power wires connected to the amp im going to do see if that's what it is. But DAMN I'm very happy how well the zv5's handle this power they barely get hot thanks for the reply man 

  • Like (+1 Rep) 1
Link to comment
Share on other sites

4 minutes ago, josephj86 said:

It only happens with the 8k my 4 ch stays on, my voltage doesn't drop much at full tilt drops to 13.4 and I have the amp is at 1ohm I've double check every connection coukd be ground location as well im going to try grounding in a different location. I think I know what it might be just from looking at the picture I noticed something that might be affecting the amp if you look at the right side of the trunk the strong arm drops pretty low I think that it could be pulling the power wires connected to the amp im going to do see if that's what it is. But DAMN I'm very happy how well the zv5's handle this power they barely get hot thanks for the reply man 

Hopefully that's the case and it's an easy fix. 

That does look like a dope setup! Is the front of the box completely sealed off from the trunk? 

2011 Chevy Silverado under construction

My build log here. Check it out! 

 

Link to comment
Share on other sites

1 hour ago, josephj86 said:

You know, never enough bass..... im getting about 1.6 ohms from each sub there dual 1 ohm I have each wired to 2 ohms 

I was talking about the ohms on the grounds 

06 Charger

Pioneer double din

Pioneer 6.5 and 6×9's

Knukoncept Krystal kable rca's

0 ga knukoncept kolossus wire 

Big 3 same wire ^ 1 run 

8g karma ss speaker wire

Sundown sia 3500d at 1ohm

2 Sundown U series 12's

Duralast platinum agm H7 (Main)

Xs power d3400

Trying to find a ho alt

 

 

Link to comment
Share on other sites

1 hour ago, josephj86 said:

Yes it's completely sealed

I'm working on my box in a dodge charger gonna seal it up u got any tips on how to go about it

06 Charger

Pioneer double din

Pioneer 6.5 and 6×9's

Knukoncept Krystal kable rca's

0 ga knukoncept kolossus wire 

Big 3 same wire ^ 1 run 

8g karma ss speaker wire

Sundown sia 3500d at 1ohm

2 Sundown U series 12's

Duralast platinum agm H7 (Main)

Xs power d3400

Trying to find a ho alt

 

 

Link to comment
Share on other sites

If the amp is shutting off, it's hitting some sort of protection.

3 things to check. And that means actually check it - don't assume anything is good :P

1. Low voltage protection on input. Check voltage at the amp when the issue occurs. Literally, put a DMM or voltage gauge into the input on the amp with the power wire. Measuring it anywhere else will tell you nothing.

2. Over-current protection on the output. Either you're wired differently than you think / too low, or there's something shorting out. Verify your wiring to the subs in a quiet, wind-free area is the DCR you expect.

3. Verify that the voltage of your turn on wire isn't dipping and telling the amp to turn off. This would also be checked at the terminals on the amplifier.

  • Like (+1 Rep) 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...