Jump to content

Why is my DD-1 and Oscilloscope better at detecting clipping than my AMM-1? (VIDEO)


Recommended Posts

I finally added the AMM-1 to my toolbox. I received it last week and of course I decided to do some bench testing with it. However, I was pretty disappointed to discover that my DD-1 and Oscilloscope are both detecting clipping BEFORE my AMM-1 does. (See Attached Video)

 

Can anyone else with an AMM-1 and a DD-1 or Oscilloscope confirm this same performance? My DD-1 is the older "Made in the USA" version but my AMM-1 is the newer "Made in China" version, so could it be a quality control issue? I'm just wondering if I might have gotten a defective AMM-1 or something. I mean it's gotta be defective right? You can clearly see the signal is clipped on the oscilloscope long before the AMM-1 ever picks it up. Of course the DD-1 is all over it though so why would the $450 AMM-1 not be performing just as good as the DD-1? I tried sending an Email to [email protected] but haven't received a reply yet. @meade916@TonyD'Amore

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 98 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...