Jump to content

Need a new Alternator I need some help


Recommended Posts

Alright so i have a 97 blazer and the stock alt isnt recharging my battery enough so i cant even run my subs and its at 500watts and im about to put another 500watts in for an L5 and if it isnt running what i have it sure as hell wont run what i wana put in. but like what happens is that ill be going and it just shuts off but the meter in my car goes down so I figure either my alt isnt strong enough and its a 105 stock , or my battery just is that shitty but what i want to do is get a 150amp alt or 160 . then im getting a kenetik battery

Link to comment
Share on other sites

Have you done the big 3?

Follow this link

replace your starting battery as well

Big 3 will help out alot..

Edited by Army_guy614

The DC Integra 3 18s to 6 15 build log

Team_DC-Derrick's Youtube

Team DC Audio

where theres a will theres a wall.......

I just realized Steve has reach Voldemort status, over on JP's site he is the one who will not be named....."We dont speak his name over here, fearing it will destroy us" LOL not even in hush tones

Link to comment
Share on other sites

well, your trying to run some power thru 12g LOL thats alot of strain on it, do those in 0g and see if it helps at all, what size is your power wire going to the back?

The DC Integra 3 18s to 6 15 build log

Team_DC-Derrick's Youtube

Team DC Audio

where theres a will theres a wall.......

I just realized Steve has reach Voldemort status, over on JP's site he is the one who will not be named....."We dont speak his name over here, fearing it will destroy us" LOL not even in hush tones

Link to comment
Share on other sites

Okay im going to put this info down for people who want to help me out. I just checked my Battery and its putting out 14 volts when the car runs with out anything else running as in my sound system. So im guessing i need to get a bigger alt i was thinking 150 sound good?

Link to comment
Share on other sites

Alright so i have a 97 blazer and the stock alt isnt recharging my battery enough so i cant even run my subs and its at 500watts and im about to put another 500watts in for an L5 and if it isnt running what i have it sure as hell wont run what i wana put in. but like what happens is that ill be going and it just shuts off but the meter in my car goes down so I figure either my alt isnt strong enough and its a 105 stock , or my battery just is that shitty but what i want to do is get a 150amp alt or 160 . then im getting a kenetik battery

Get a big battery for the rear....I ran ~2000wrms off my stock alt with a good battery under the hood and a hc2400 in the back and didn't drop any lower than 12.6v at idle....and dropped to 13.6v driving....

and not until I ran about ~3500wrms off my stock alt with 3 batteries.....did I drop into 11.6v

Edited by wL<3bass

Vehicle: 1997 S10 Blazer 4dr 4X4

Exterior: Rear End Bagged, Black Grill, Lifted 2"

Amplifiers: Rockford Fosgate T8004 & T10001bd

Batteries: 2 Stinger SPV35, Kinetik HC2400

Electrical: Big 3, DC Power 290amp Alternator w/ MLA at 15.5v

Enclosure: 4.2 ft³ @ 33Hz 84sq.in. of port (20sq.in. per cube)

Headunit: Eclipse CD3200 w/ 80G iPod

Mids/Highs: Rockford T152s (a-pillars), Rockford T162s (doors)

Subwoofers: 1 15" Fi BL Fully Loaded

Wire: All 1/0g Kicker Hyperflex

My YouTube Videos

My Fiberglass A-Pillar Build

My "Seamless" Looking Box Build

My DD1508 T-Line Bandpass Build "Seamless" w/ Acrylic Windows (for '05 TrailBlazer)

My Stealth 8" Fiberglass Build (for '05 TrailBlazer)

My Build For A Friend's '08 Cobalt 15" BL Sealed Off From The Trunk

My feedback/references...

Link to comment
Share on other sites

So I should get a battery and put it into the back of my car and that should fix it ? let me throw this info in too b.c it is a big thing i guess , when i got this car the dealer was a shitty place and they needed to put a new battery in new tire rods and some balljoints and i think they went cheap on the battery b,c its nothing great and i think that the amp hours just arnt what they used to be. so i was thinking like an optima yellow top to replace it

Edited by TeejayBee
Link to comment
Share on other sites

i run 3000 rms off a stock 90 amp alt LOL.. it does ok for most songs.. but i dont blast it full blast all day either.. Just change your main battery, put another one in the back and you should be fine *I think... and do the big 3

The DC Integra 3 18s to 6 15 build log

Team_DC-Derrick's Youtube

Team DC Audio

where theres a will theres a wall.......

I just realized Steve has reach Voldemort status, over on JP's site he is the one who will not be named....."We dont speak his name over here, fearing it will destroy us" LOL not even in hush tones

Link to comment
Share on other sites

i run 3000 rms off a stock 90 amp alt LOL.. it does ok for most songs.. but i dont blast it full blast all day either.. Just change your main battery, put another one in the back and you should be fine *I think... and do the big 3

^This.

Vehicle: 1997 S10 Blazer 4dr 4X4

Exterior: Rear End Bagged, Black Grill, Lifted 2"

Amplifiers: Rockford Fosgate T8004 & T10001bd

Batteries: 2 Stinger SPV35, Kinetik HC2400

Electrical: Big 3, DC Power 290amp Alternator w/ MLA at 15.5v

Enclosure: 4.2 ft³ @ 33Hz 84sq.in. of port (20sq.in. per cube)

Headunit: Eclipse CD3200 w/ 80G iPod

Mids/Highs: Rockford T152s (a-pillars), Rockford T162s (doors)

Subwoofers: 1 15" Fi BL Fully Loaded

Wire: All 1/0g Kicker Hyperflex

My YouTube Videos

My Fiberglass A-Pillar Build

My "Seamless" Looking Box Build

My DD1508 T-Line Bandpass Build "Seamless" w/ Acrylic Windows (for '05 TrailBlazer)

My Stealth 8" Fiberglass Build (for '05 TrailBlazer)

My Build For A Friend's '08 Cobalt 15" BL Sealed Off From The Trunk

My feedback/references...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 132 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...