Jump to content

Install Log MechMan 300a Alt


Recommended Posts

Just got my new 300a alternator from MechMan. Matt has been great to work with. Super fast shipping. This will be an install log of this monster alternator going into my 1993 Ford Explorer 4.0L. Currently there is an XS Power d3100 under the hood and one in the back. The system consists of a Sundown Audio sax-100.4 for the doors and a pair of Sundown saz-3500s @ 0.5ohm each powering a pair of Sundown Z v.2 12"s.

Start by removing the intake duct.

100_3863.jpg

Once it's out the way there is plenty of room to get to the alternator.

100_3864.jpg

Next thing is remove the belt.

100_3866.jpg

There are three mounting bolts. Unbolt those, undo the plugs, and unbolt the battery wire from the back of the alternator.

100_3865.jpg

Here's a few pics of the stock 95a alternator next to the MechMan 300a.

100_3867.jpg

Here you can see the dedicated grounding stud.

100_3868.jpg

Notice the much smaller pulley. Helps keep output up at idle.

100_3869.jpg

100_3870.jpg

Close up shot of the larger than stock + stud and dedicated grounding point.

100_3872.jpg

Now simply reverse the steps above to install the new alternator.

100_3873.jpg

TESTING:

Using a single saz-3500 @ 0.25ohm as a load on the system we clamped 180a of current @ 14.9v from the alternator at idle which is between 600-700rpms. At 1500rpm we clamped 250a @ 14.9v with absolutely zero voltage drop. A single amplifier @ 0.25ohm just wasn't enough of a load to get full output from the alternator.

Just before leaving I got my second amp installed and hooked up. Won't get any more clamp testing done until tomorrow but cruising home with the volume full tilt playing music the voltage held up great. Worst voltage drop was into the mid 13v range on hard bass notes.

teamnemesissundown-1.jpg

Link to comment
Share on other sites

Nice install! I would think about getting rid of that isolator,not from my experience but I have read alot of negative posts about them.Please don't be offended ,just trying to help!

2001 Southern Comfort Suburban sittin on 26"s

Eclipse 6620 double din head unit (2004 dash mod)

4-AQ 3500D amps @1 ohm

8-Cadence 6.5 midbass 4- in each door.

Image Dynamics Cd 1 pro HLCD

4-runs of KnuKoncepts 1/0 power wire

4-DC AUDIO lvl 4 xl 18"s in a wall

2-MECHMAN 270 AMP alternators(2 more on the way)xs power VCM

7-Deka intimidator group 31 batts(soon to be Xs power)

2-Rockford Fosgate Prime r300.4(1 bridged on mids, 2nd on CD1 horns and rear door speakers)

1-Rockford Fosgate 360.2(operated by Palm tungsten T5)My link

Link to comment
Share on other sites

Nice install! I would think about getting rid of that isolator,not from my experience but I have read alot of negative posts about them.Please don't be offended ,just trying to help!

I could be wrong but I think thats an external voltage regulator not a battery isolator.

Edited by 01 S-10

TDH FTW !!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 147 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...