Jump to content
 

Haro Christian

Members
  • Content count

    29
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Haro Christian

  • Rank
    120db

Profile Information

  • Gender
    Male
  • Location
    Houston, TX
  1. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    I have checked that too, replaced with new ones and even old ones I know for sure worked and no dice.
  2. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    Rca voltage doesn't divide when you use a y splitter, if you have 2v coming to the split you'll have two ends with 2v coming out.You need to use a lot of splitters before you'd notice any appreciable voltage drop. I used to have the sub-out split to 2 mono amps, no problem. All I did was add another amp same brand and model, added another splitter and it craps out. I can't even run 2 amps anymore. Old setup Main Line to Dual MONO Amps Right ® Left (L) R to Female/Male Y-Splitter to female/female adapters to RCA's going to Right Input on Amp1 & Amp2 L to Female/Male Y-Splitter to female/female adapters to RCA's going to Left Input on Amp1 & Amp2 WORKED FINE Now, I added 2 woofers, another same brand/model amp, added a new battery. Replaced Female/Male Y-Splitters with Male/Females. Now: R to female/female adapter to Male/Female Y-Splitter 1 end of splitter to R on Amp1 the other to another male/female Y-Spitter then 1 end of splitter to R on Amp2 and R on amp3 L to female/female adapter to male/female Y-Splitter 1 end of splitter to L on amp1 the other to another male/female Y-Splitter then 1 end of splitter to L on amp2 and L on amp3 The signal sounded completely wrong as if I had something crossed. I checked all my wiring and it was correct. After looking into it deeply, I found that the signal dropped the moment I connected an additional amp. It only sounds good when it's not split. I reverted back to the old setup and now that didn't even work. It only works with 1 mono amp, my sub-out outputs on the HU are good. I even tried the regular front/rear HU outputs and that even drops when I connected to mono amp. Works fine with my amps for highs on Y-Splitter. I'm puzzled because I checked, rechecked, and rechecked everything and it's all wired right. I just don't see why it wouldn't work back on two sub amps. Ugh ??
  3. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    So after searching the web, I see I need a Linear Driver... AudioControl Matrix seems to be a good one, but will that work just for my subs? Or will I simply hookup connect my highs and Y-Split the sub out to the three amps? Sorry, I have seriously been out the system game for a looooong time.
  4. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    No the do not, only inputs and can't be strapped.
  5. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    I found the issue! It's not the box nor the power going to the speakers, it's the freaking RCA sub-out signal!!! Yes, you were correct in the width of the box kind sir, it was 49". The measurements I used were 23"H x 49"W x 58"D Port is 21.5"H x 15"W x 10.5"D (2Walls) tuned to about 30Hz per Torres Calculator.When I use the RCA Y-Splitter, it cuts the signal drastically it kinda sounds like when you have cables crossed. I double checked my wiring and everything is legit. I tried running just one amp with the sub-out main RCA to 1 amp and its loud. But as soon as I try use the Y-Splitter it drops. Any idea? My head unit is a Pioneer AVIC-X940BT
  6. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    No, I have three amps now, running a set of woofers to each at 1ohm at amp. RMS per amp is 2000 @ 1ohm and 2 extra batteries.
  7. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    i did that just now, looks like im in the 100's wtf. port not deep enough? its only 10.5" deep. i been on youtube and see the ports similar in height and width but deeper. UPDATE I have three amps running at 1ohm per 2 subs. Massive Audio N4's are the brand and models still sounds like crap
  8. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    After adding the 2, Torres shows a tuning frequency of 30.67Hz, however, the subs are facing up port back, when I check the Sup Upward box, it shows a freq of 31.16Hz.
  9. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    I will try that later when I get home.
  10. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    They have a TON of cone area for 15s being that they're square @OP how much air a port moves is greatly dependent on the power applied and frequency played. What do you believe the problem to be? Do you have any odd loading issues? I think its getting enough power, I am using a Massive N4 amp running at about 2.6ohms.
  11. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    The woofers are dual 4ohm. I have them wired, temporarily, to 2 Massive Audio N4 amps at about 2.6 ohms Amp Specs: RMS: 2000w x 1 PEAK Power: 4000w x 1 RMS @ 2ohms 1000w x 1 Min Impedance: 1ohm
  12. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    Yup, 58inches, i have plenty of clearance. I assume I need to tune lower?
  13. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    uhhhhh, what would 20% of that port be?
  14. Haro Christian

    So, I built my box for 6-15" Kicker L7.... HELP

    Kicker suggests a min of 3cuft and max of 6cuft per sub. I tried to get the max i could using the space i am not using in vehicle.
  15. Haro Christian

    Sub up Port back? Or Sub Back Port Back?

    On one of my post, I was told that subs up port back gives you a much better sound than subs back port back... I built my box but think I screwed up on the port because it does not give out much air. It was my 1st build attempt for 6-15" L7's
×