Jump to content

Welcome to the SMD forum!

Bhaazaher

Members
  • Content Count

    17
  • Joined

  • Last visited

Everything posted by Bhaazaher

  1. currently i am having morel virtus 602 running with skar audio SPX-T tweeters since i fried the morel one. running on an audison sr4 amp so i am having an issue with lack of volume or lack of midbass when i turn up the volume.. (running an dc audio level 3 as a sub) so i dont know what is the problem.. is the component set is not strong enough and the sub overpower their volume? or i have another issue... and if so. what do you guys suggest getting to complete my system.. (looking for an SPL components)
  2. i forgot to mention.. i have an smd dd1 plus so all the tuning now safe.. but i want to change the tweeters cuz they are weak
  3. hello guys.. so running a a dc audio level 3 sub (1000rms) in a skar audio skv2-1500d MOREL virtus 602 components (replaced the tweeters to jbl gto 19t cuz i blew the morel ones) on a audison sr 4 (connected at 2ch @ 175wrmsx2) so i am thinking about changing my tweeters to new ones since these one are 3 ohm independence and abit weak and the original ones are 4ohm (i am fearing they are the cause that my system breaks down at high volume...) i was thinking about changing them to a new powerful ones with 4ohm independence soo one of the guys told me when you have such a powerful sub (1000rms) you MUST have a super tweeter to reduce vibration and keep the tweeter safe.. so what do you think guys? can i stick with a normal tweeter or should i go to a super tweeter? and in any case.. what tweeters you guys recommend that can handle the watts from the amp
  4. thank you alot there mate.!! you helped me alot today i connected the speakers on 2ch and shit.... they are loud i couldnt turn all the way up lol... now my problem is the acoustics and the tunes... these are the ones that i have no idea how to do it... as for tuning until distortion is pretty simple. i know a guy who owns a DD-1 i`ll pay him a visit. but as for subsonic Filter , LPF AND HPF i am having a hard time to figure it out.. but i`ll do abit of research over them and see how it goes.. if you have any tips for them.. i`ll be happy to hear them out many thanks mate and thank you for your time!
  5. to be honest no i dont have sound deadening.. but i am thinking about going for it.. so you suggest that i grab a multimeter go for a 2ch mode.. and turn them for about 130W (they can handle 140W)
  6. the mounting is A stock location, budget lets just say. i would go for a 400-500$ for components
  7. This is the amp rating so you don`t get confused.. Nominal power (RMS) @12 VDC; 1% THD : 4 Ch @ 4 Ω 45 W x 4 Output power (RMS) @14.4 VDC; 1% THD: 4 Ch @ 4 Ω 65 W x 4 4 Ch @ 2 Ω 90 W x 4 3 Ch @ 4 Ω 60 W x 2 + 190 W x 1 2 Ch @ 4 Ω 175 W x 2
  8. an aftermarket headunit.. its a jvc kw-v21bt and for the amp i guess it produce enough power.. as you can reach 350W RMS for a pair in 2ch @ 4 ohm the problem i can't find a decent components that can handle that RMS
  9. yeah they are not loud enough.. and people are saying if i connect them in 2ch i`ll fry them up
  10. 4 ch @ 4 ohm = 65W RMS X 4 4ch @ 2 ohm = 90W RMS X4 the morel = 140 watts RMS (300 watts peak power)
  11. Hello everyone. so i am searching over the internet for some decent components that will match my system but i am a bit confused now.. so at the moment i am using Morel virtus 602 components with JBL GTO19T tweeters(i fried the morel ones and replaced them with the jbl) as for the amp i am using audison SR4 (currently using 4 ch but willing to go for 2ch) the amp gives in 2 ch 175W X 2 @ 4 OHM Running a 1000 RMS DC AUDIO level 3 sub so i am looking for components that will match the system and the amp + people are suggesting that i should add 6/9 speakers and i dont think its a good idea since i have a kia rio sedan and i dont have 6/9 in the rear what should i do? get another components put them on the rear on 4ch get a better components and run them on 2ch or go for the 6/9 in the rear? Thank you all for your time
  12. Thank you all for the support. i had my system check and the guy told me that my monoblock amp is the issue at high volume it sends bad signals back to the head unit through the RCA which cause the head unit to go in a protection mode. (Im not sure that what he is saying is true i dont find it makes sense) So i am thinking before buying new amp im gonna change the RCA and see how it goes. anyone dealt with this issue before? (about amp sending back signals back to the rca?) if it is common let me know thank you all for your time
  13. hello everyone and thank you for your time... i recently installed a new system in my car SETUP : DC AUDIO LEVEL 3(connected on 1 ohm) , Skar skv2 1500D Monoblock , MOREL VIRTUS 602 as for components, Audison SR4 as for 4 channel amp, under the hood is a deep cycle AGM battery, and a 1.5farad capacitor in the trunk jvc kw-v21bt headunit WIRING : 0AWG from the hood battery to the monoblock and the ground is 0AWG from the amp to the chassis (about 20cm) , 4AWG (+ AND GROUND) from the hood battery to the 4 channel amp, and ofc high end cables and RCA from the headunit to the amps... big 3 : NO Problem : when i play at low volume everything works perfectly, as soon as i raise the volume up to half (mono gain is 1\10) the music dies. the amps doesn't go into protection and the voltage doesn't drop! , when i close the gain i can go to full volume with no problems, Notice : i currently using a stock grounding from the battery + a 16AWG to the chassis ( i think its weak), sometimes when the bass kicks really hard without the music dies, i hear a bit of distortion coming out from the tweeters What could be the issue? Thank you all for your time <3
  14. Okay so running a 0awg from the battery to a 1.5farad capacitor and then to the amp using stock alternator (90A) which i know is a bit weak.. but it clips from the very first second it start to play. So i am pretty sure the electricity isnt the problem. when i had the dc audio level 5 i had 4 xs power batteries running to the amp and still had the same problem. as for the system it self . I am using jvc kw-v830bt morel virtus 602 running on audison sr4 and thats all
  15. Sooo. Is there a chance that my amp has a defect in it and it produce “bad clipped waves” to the subwoofer?
  16. Hello guys. so last year i had dc audio level 5 running on an dc audio 3.5k amp on 1ohm. Somehow the clipping indicator on my bass knob(the original one that comes with the dc audio 3.5k amp) starts to blink almost in every peak. Which is somehow okay. But as soon as i turn the volume up to about 50% or more. Every bass effect clips. (No distortion sound no buzzing nothing) only it clips. Which makes me a bit worry. so i tried to look for it. And a dc audio dealer told me that my dc audio level 5 got problems. So i belevied that my subwoofer was doing all the clipping things. So i recently changed a car and manged to change my dc audio level 5 to a brand new dc audio level 3. (Still running the same amp but on 4ohm) and still getting the same clipping problem. what may cause this clipping thing? And how can i solve this. For those who isn’t familiar with dc audio (dc audio level5 rated at 3500wrms/7000w peak dc audio level 3 rated at 900wrms/1800w peak Dc audio 3.5k amp rated at 3500 wrms at 1 ohm and 750wrms at 4 ohm) im abit new to this business. So take it easy on me. Thanks for reading folks!
×
×
  • Create New...