Jump to content

Recommended Posts

Ok so here's the setup. I ran rcas to my Clarion EQ from the head unit. Sound is crackly and weak. But if I touch the positive to the negative sound is clear. And the rcas are good because if I run it straight to the head unit it is fine. 

Share this post


Link to post
Share on other sites

9 hours ago, slowfkncar said:

Wait, what do you mean if you touch the pos & neg?

The positive post of the rca cord aka the long part to the negative aka the outer area of the jack

Share this post


Link to post
Share on other sites

You have a bad ground somewhere, it is grounding out when you touch it. It may be an internal or external ground. Recheck all the grounds you can. If nothing improves then it is an internal grounding issue within the clarion unit. Is it a new unit?

Share this post


Link to post
Share on other sites
5 hours ago, SawDawg said:

You have a bad ground somewhere, it is grounding out when you touch it. It may be an internal or external ground. Recheck all the grounds you can. If nothing improves then it is an internal grounding issue within the clarion unit. Is it a new unit?

Ok so I'm a idiot. It wasn't the ground it was the power wire. So the reason is I didn't think of that was because it has lights so it got enough power from the remote wire to light it up but not enough to power it on. So in my testing phase I disconnected it and forgot. One of those I'm a dumbass moments.

Edited by Honda76
Error

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...