Jump to content
Sonic Electronix

My sub doesnt work for me, but it works for Fi


Recommended Posts

Try it out of the box, on a other amp.

Could be bad connection or something in you're box.

Tried it out of the box and it did the same thing.

And again wouldnt that mean my old bl with the same wiring not work? But it does

Link to comment
Share on other sites

check for power on sub, something wrong with wiring

I dont have the sub in my possesion, Im trying to understand why it works for them, but not me. Meaning its in Vegas @ Fi, And AGAIN wouldnt that mean the wiring going to my old bl (same wiring) would not work. (but it does)

Please read the top before posting, not trying to be a dick, but i just want to get to the bottem of this

Link to comment
Share on other sites

Wire pushed in to far and touching the basket therby causing the amp to ground the the basket?

J

Possibilty, BUT i dont think that happened, because I dont have that much stripped off of any wire, and i dont believe it went that far. And doing that 3 times in a row? But ill remember that when i test it. Thanks

ANY MORE SUGGESTIONS??

Link to comment
Share on other sites

I dont have the sub in my possesion, Im trying to understand why it works for them, but not me. Meaning its in Vegas @ Fi, And AGAIN wouldnt that mean the wiring going to my old bl (same wiring) would not work. (but it does)

Please read the top before posting, not trying to be a dick, but i just want to get to the bottem of this

i'm just trying to help, cause i had kind of same problem, but with different sub

Link to comment
Share on other sites

i'm just trying to help, cause i had kind of same problem, but with different sub

I understand man, but just think before you post. NOW BACK ONTOPIC

Link to comment
Share on other sites

yeah my bad I didn't think about that.

it has to do something with your amp if the sub is fine.

Amp plays the old Bl perfetctly so i cant see that as being the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Who's Online   0 Members, 0 Anonymous, 431 Guests (See full list)

    • There are no registered users currently online
×
×
  • Create New...