Check out the SMD Store @ WcCarAudio.com!

Jump to content
 
 

snafu

The Big 3 - Problem Solved.

Recommended Posts

We use JL Audio full spec tinned OFC. Honestly, in my time in the business (20+ years), I've never seen a cable that I like better. The RF cable is similar, but it is not tinned.

Share this post


Link to post
Share on other sites

Im about to do this but im not sure what size fuse to use between the batt and alt. Its just a stock alt in a 2007 silverado classic. This is the only thing holding me back

Share this post


Link to post
Share on other sites

150A fuse will be fine for a stock alternator. Your Silverado also has an inductive ring on the charge lead so I recommend our 2 AWG kit, because you can fit the 2 AWG cable through the ring along side the factory ground wire and the 1/0 AWG will not fit. If you want to use 1/0 AWG, then I need to make a slight tweak to the kit for this vehicle.

Share this post


Link to post
Share on other sites

Having problems i connected my + alt battery + then body- to batt- then when i put my- engine block to- battery my car electrical system go s hay wire. But wheni took the engine - off an lleft the other 2 everything is fine what am i doing wrong? 07 impala 3 yellow tops

Share this post


Link to post
Share on other sites

i have 4 power acoustik mofo 15 on a hifonics brutus elite 2500.1d. i just did the big 3 on my blazer and it hits harder than ever. but... i used to have about 10-15 seconds of play before battery gauge would hit 12 and now it instantly drops to 10 as soon as it hits. any idea what might be causing it to drop so fast now?

Share this post


Link to post
Share on other sites

thank you that helped quite a bit. what size alt should i run if im planning on putting 2 hifonics bre2500.1d's in? i want to get my electrical done before putting in another amp.

Share this post


Link to post
Share on other sites

I don't know if this is the right topic to post in to ask my question but I thought I'd give it a shot.

The Big 3 upgrade:

1.I grounded my engine block to the frame(4g)

2.Upgraded power wire to alternator(4g)

3.Grounded battery to the frame(4g)

Now my question is do I ground my alternator to the frame too?? I just barely heard about The Big 4

( and fyi the reason I used 4g is bcuz thats what I had to work with and also I only have 1 1800 watt amp, I WILL upgrade to 0g soon)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×