Jump to content

Recommended Posts

So this is quite upsetting. Had the amp running before I had to get my transmission rebuilt a few months so i took it out . When I got my truck back (thank god) I was so exciting to throw the 10k back in . So hook it all up threw the fuses into the ANL block powered it on, all of a sudden I just heard a pop in the back so instantly I thought to myself that the fuse blew ....little bit of smoke started flowing out the amp when I went back there to investigate. Not a good sign when it smells, so up n smoke it's done . Went to an electronics specialist that lives down the road from me (luckily enough) he knew what was potentially  wrong . (Mosfets,lead wires, resistors) said he couldn't have repaired it because it was alot more complicated for him to go in depth. So now im stuck and have spoke to a few amp repair shops. They all told me to send it in. So I'm waiting to see who I should go first. Any ideas??

 

Have a few pics of the guts

20211220_143646.jpg

20211220_144320.jpg

20211220_144231.jpg

20211220_144303.jpg

20211220_144335.jpg

20211220_144352.jpg

Link to comment
Share on other sites

Couldn't tell you exactly how old the amp is but I've owned it for about a year or so. Never had an issue with it when I got it off a fellow basshead on the Facebook marketplace . So I'm just praying this point that it can be repaired and by all good gracious keep it's power rating ++

Link to comment
Share on other sites

1 hour ago, Cruz18s420 said:

Couldn't tell you exactly how old the amp is but I've owned it for about a year or so. Never had an issue with it when I got it off a fellow basshead on the Facebook marketplace . So I'm just praying this point that it can be repaired and by all good gracious keep it's power rating ++

I was just wondering maybe it was still under warrantee. Doesn't sound like it unfortunately. 

Do you have a place you're going to take it? 

2011 Chevy Silverado under construction

My build log here. Check it out! 

 

Link to comment
Share on other sites

1 hour ago, Cruz18s420 said:

Yeh I spoke with the Amp medics in Florida and The amp lab. Both very responsive and helpful. I'm just waiting to jump the gun on it once the holidays are over lol

That does suck though, having to deal with a blown amp

2011 Chevy Silverado under construction

My build log here. Check it out! 

 

Link to comment
Share on other sites

Send it to ampmedics.

They have repaired a few od my boards. 

Also, another casez where fusing the amp, doesnt do much. Saved more on a repair,  maybe. 

 Save the board, never. 

Best of luck. I actually loved my dc 10k. Though it also needed work after a couple seasons. Not even wired real low.

Again, good luck. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...