Check out the SMD Store @ WcCarAudio.com!

Jump to content
 
 

Recommended Posts

so i recently noticed the other day that one of my subwooers is playing harder than the other. i first thought that one wasnt playing at allbc i couldnt hear nor feel it moving. no today i toook outmy box and checked all my wiring and nothing was wrong. checked my rca's and nothing was wrong. i then swapped the subs and cranked it up and the problem stayed on that channel. then i swapped the rcas around and the problem still stayed in the same channel. the subs play just fine on channel 3 but veryyyy low on channel 4. both channels are using the same x over and gain. so could it be that the channel that is playing low could have a short n the amp or what? help please

  • Like (+1 Rep) 1

Share this post


Link to post
Share on other sites

Only real way of telling is to swap amps, have a friend hook his up and if that works then it's your amp. It does sound like its your amp

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...