Jump to content
WalledSonic

(2) XS Power D3100's w/ Copper Bus Bar

Recommended Posts

EDIT 11/9/17: 2 BATTERIES REMAINING. I can still cut the bus bar to the appropriate length or sell as is, also.

I sold my second car and bought some lithium, so I dont need my AGM bank anymore.  I'm trying to shed some pounds from my current audio build.  

These were bought 1 year ago and were in my last build (Chevy Sonic, walled).  I kept these properly charged at all times and these have never seen voltage lower than 11.8V.  I charged them on my bench 10ish weeks ago with the PSC60 and they are still resting at 12.89V as of yesterday.  Internal resistance measures under 18milliohms.

I am asking $300 per battery, and $100 for the copper bus bar ($170 value, plus they are already drill and tapped).  I will personally deliver to (almost) anywhere in central/east Texas or Louisiana.

36904680206_9ed5be652f_k.jpg

Here's a pic of the bank in my previous build, being all sexy as f*ck:

36222839911_cc7344e9cc_k.jpg

Edited by WalledSonic
only 2 batts remaining
  • Like 1

Share this post


Link to post
Share on other sites

$250 each, $850 for the (3) batts plus bus bars.  I'll consider a lengthy drive if the buyer is serious.

Resting at 12.91V, last charged with the PSC60 about 7 weeks ago.  Just bought a 3rd JY, so I dont have any use for these AGMs anymore.  Like new, low ESR, never seen a deep cycle.

Share this post


Link to post
Share on other sites
On 10/25/2017 at 8:12 PM, WalledSonic said:

Need batteries?  Hollerrrrr

I know that you are across the country but would you ship by chance?

 

PM me if you wan't I'd be interested in 1 maybe 2 (soon)

Share this post


Link to post
Share on other sites
4 minutes ago, rocking.that.eclipse said:

I know that you are across the country but would you ship by chance?

 

PM me if you wan't I'd be interested in 1 maybe 2 (soon)

No prob man, I have these awesome batteries just sitting around.  I'd love to get them into someone else's rig and free up some garage space :)

PM otw

Share this post


Link to post
Share on other sites

My cousin might need 2. He hasn’t text me back but I’ll pm you if he does. 

  • Like 1

Share this post


Link to post
Share on other sites
Just now, juan777 said:

My cousin might need 2. He hasn’t text me back but I’ll pm you if he does. 

Word, hit me up.  Free delivery since you're local!  I can also cut the bus bar down if he needs some copper that already fits.

Share this post


Link to post
Share on other sites

Bizzumpppp... just sold one last night, only have 2 remaining.  $250 each delivered in Houston-ish areas.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Krisztián Arnold
      Hey guys!

      So recently I got myself a pair of Rockford Fosgate P3 D4 subs, and started to play with them a little. 
      However I can't quite see the numbers I was hoping for. I got to thinking what can cause this little anomaly. I am thinking maybe it is my battery, because everything else semms to be okay.
      My setup consists of 2 RF P3D4 subs, a Hifonics Brurus BRX2016.1D, and an XS power D975. I choose theese things because it seems to fit together just fine to cover the 1000-1500 watt range, but apperently I was wrong somewhere. 
      All of this is currently out of a car, so maybe it is the problem. However, I have seen many videos where people get their equipment out form a car for a period of time, and they can reproduce almost the same power, and that is the reason I am worried a bit by now.
      It also can be a tuning problem, because I only owe a multimeter ( whitch is a True RMS meter by the way) and a clamp, but I doubt is is the real reason.
      Thank you for your answers in advance! I hope you can help me out! 🙂
       
    • By Kraken
      So I have a zv3 12 now. Im upgrading parts to a 15" zv4 frame, zv4 spl soft parts/zv4 coil, and night shade spider. Im only keeping the zv3 motor. I am looking for a zv3, any size, 10 through 18. I just need the motor, also if its blown or working, i still want it. Id rather get a blown one for the price difference though. If you have a blown zv3 or know anyone with even just a zv3 motor, let me know. Thanks guys
    • By Krisztián Arnold
      Hey guys! 
      Maybe it is a dumb question, but I'll ask it anyways. 😄
       
      So I purchased an XS power D 975 last summer, and I am extremely happy with the performance it provides. However I still do not understand how would a 35AH battery with it's own 12.8-13.0 volts support a 1000/2000 watt system.
      What do you think about the accuracy and the reality of these ratings in the real world? (not just testing in the lab) 😮
      I also do not understand how can I tell if the battery is low on charge. Like when I use it ( lets say for 25 minutes and cranking it) and stick a voltmeter to the probes right after that it shows for example 12.56 volts. The maual says you should get cahrging when the volts are below 12.6 and it is really stict so you should kepp it that way. So I set up my charger ant when I test it again a few minutes later it now showls like 12.73.
      How is that possible? And if the cells fill up eachother how can I tell when it is drained or not? 🤔
      Thanks for the answers! 😀😀 
       
    • By duder
      hello everyone, 
      just a newbie here with some questions In regards to my wiring and battery.  But first a little background and my agenda.  my car is an 07 Volkswagen rabbit 4 door 2.5l auto.  I purchased this car as a commuter car, as my 01 Jeep Cherokee wasn't good in the fuel mileage area.  when I purchased the rabbit used, there was some previous audio work already done.  there was a Pioneer double din display installed, along with a power amp for the mids.  Now maybe I am the little over kill type, but I don't feel that the 4 awg power/ground wire is adequate enough. especially considering its CCA.
      Now in my Jeep I ran 1/0 welding cable, that mild system was a mean machine powering a Kicker CVR 2 ohm 10" sub in a sealed box, along with a MTX mid amp powering 4 kicker ks600s.  
      i don't think 1/0 is necessary in my Rabbit let alone my Jeep.  I am working on a similar system,  though my current mid amp is an audio planet 1200watt 4 channel amp and my sub is a Skar audio rp350.1 with a ix 10v 2.  I may upgrade the Skar, but won't know until my sub is broke in.  my goal is a loud and clear system.  
      I was thinking of upgrading my wire to 2 awg, doing the big 3, and replacing my battery. so I thought would get you opinions.  one thing that comes to mind with my Jeep when I was pushing my system,  my lights and volt meter would drop.  I never performed the big three with it nor did I get a better battery.   my concern is that I will have the same issue and along with my battery not testing so well, I will end up dead in the water someday. 
      some day I will focus on the door speakers, eq, and crossovers.  but for now, I want to focus on adequate power.
       
      thanks
    • By RudyRudez
      STEPPING IT UP A NOTCH And I Need Your help 😁 - I Recently installed dual 0ga runs for my bc3500d crescendo and have a few questions about my next setup. 1st. what size fuses should i use for under the hood since theres 2 runs? 2nd should i fuse after my second battery ? if so what size on those ? i will be getting a new secondary battery (old one gave out) what would be a recommended battery for this amp? 3rd I'm planning on upgrading my alt, i was looking at the 320 amp mechman what you guys think? And Last (i Sold my 2 12s Crossfire c7s, thinking of getting 2 15s ) what subs would you guys recommend for this setup ? Btw All of this is going in a tahoe. Thanks in advance 🤓 
  • Who's Online   15 Members, 0 Anonymous, 907 Guests (See full list)

×