Jump to content
  •    

Recommended Posts

Uhh....sorry bro, but thats clamped power. Strapped together, 3245w at 2.5ohm at 10.8v. I can vid to prove it to you bro. I've got 1330w at 2.7ohm out of 1 alone. I also have a fellow competitor that got just over 2k at .5ohm on 1 asa1500. So research a little before you try to call me a liar or down my equipment. Powerbass amps are very good amps. Very clean and unrated on good electrical. And that's coming from a devoted sundown owner.

Share this post


Link to post
Share on other sites

I think you just want to get louder..why dont you save yourself some money and just build a larger enclosure with some good bracing n resin the indide and do some sound deadening to the trunk and cabin. Maybe some deadener and then sound barrier on top of it. Mdf isnt too expensive and sound deadener will only set you back a few hundred if you take advantage of a sale promotion. Better than sepending 1200 just for a new amp. Also whenever your batteries die on you think about getting all same brand and same group size batteries..different batteries of different group size and brand cycling charge between them can cut down on battery life for all of them. Just tryna help out

  • Like 1

Share this post


Link to post
Share on other sites

Had a Cres 3500D on my 2 12" ZV4s @ 1ohm w/ 3 Batts to wear them in, then swapped out to a 5500D and they're loving it. Mind you I've got a mighty big enclosure for what I have too but theres never been a problem :unknw:

Share this post


Link to post
Share on other sites

My (4) Zv4 18s came in yesterday. Im running 2 at the moment on an NS1. 2 of them are laughing at my NS1. Ive been beating the shiz out of them and they barely get warm and havent smelled a coil.

Define "laughing at". I hate when people say that. It means nothing. How do you know you're not a cooter-hair away from a bad day? Rant over lol.

Dude around here had two Zv.4 12's on an NS-1, and the surround was dimpling at full tilt. I'd say that's pretty near limits. Enclosure definitely plays into that though obviously.

Edited by gckless

Share this post


Link to post
Share on other sites

Has anyone had any issues with the spiders on these subs? I pulled mine out yesterday to just look it over and when I lift the cone about 3/8"-1/2" small 1/4" long tears open in the peaks of the ridges of the spider, it's only about a month and a half old and it's only been on a RF T2500.1bdcp, it's in a ported enclosure just under 2.5cubes tuned to 32hz and I've used the subsonic filter and broke it in according to what sundown had said? What gives with this thing?

Share this post


Link to post
Share on other sites

Nic watts is throwing a 5k to each of his an his zv4s are nasty!! My brother also had a single zv4 15" and he put 2 IA20.1 @.25 each daily an it LOVED it!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now