Jump to content
 
 

Recommended Posts

Hello guys.

so last year i had dc audio level 5 running on an dc audio 3.5k amp on 1ohm. 

Somehow the clipping indicator on my bass knob(the original one that comes with the dc audio 3.5k amp) starts to blink almost in every peak. Which is somehow okay. But as soon as i turn the volume up to about 50% or more. Every bass effect clips. (No distortion sound no buzzing nothing) only it clips. Which makes me a bit worry.

so i tried to look for it. And a dc audio dealer told me that my dc audio level 5 got problems. So i belevied that my subwoofer was doing all the clipping things. So i recently changed a car and manged to change my dc audio level 5 to a brand new dc audio level 3. 

(Still running the same amp but on 4ohm)

and still getting the same clipping problem.

what may cause this clipping thing? 

And how can i solve this.

For those who isn’t familiar with dc audio

(dc audio level5 rated at 3500wrms/7000w peak

dc audio level 3 rated at 900wrms/1800w peak

Dc audio 3.5k amp rated at 3500 wrms at 1 ohm and 750wrms at 4 ohm)

im abit new to this business. So take it easy on me.

Thanks for reading folks!  

Share this post


Link to post
Share on other sites

Okay so running a 0awg from the battery to a 1.5farad capacitor and then to the amp

using stock alternator (90A) which i know is a bit weak..

but it clips from the very first second it start to play. So i am pretty sure the electricity isnt the problem.

when i had the dc audio level 5 i had 4 xs power batteries running to the amp and still had the same problem.

as for the system it self . I am using jvc kw-v830bt

morel virtus 602 running on audison sr4

and thats all

Share this post


Link to post
Share on other sites

How did you determine what level to set the amp's gain? What settings on your HU are you using? You need to provide every detail about every setting on the HU and the amp in order to receive an answer as to what could possibly be the issue.

Share this post


Link to post
Share on other sites

A subwoofer cannot produce clipping. the clipping is from the signal being fed to the subwoofer. So its either from your headunit or your amp. That is why gain setting is so important. 

 

A 90 amp alternator is not going to last long in this situation.

 

Capacitor is useless for you so get rid of it as it is now it is an additional load on your electrical system.

  • Like (+1 Rep) 1

Share this post


Link to post
Share on other sites

Im just wondering   since you say it blinks clipping from the moment you start, I will assume low volume.

maybe its the  knob and indicator?  try another bass knob?  

sometimes its the little things 

Edited by XSVTOYZ

Share this post


Link to post
Share on other sites

Check your source music your using in windows media player with scope turned on to see it as it is playing to see if it is in fact clipping.

Soft clipping is not the same as hard clipping and a light cannot tell which one it is, this is where you need to learn what the sub is doing and if there are any unwanted smells coming from the sub.


01 Ford focus ZX3

Pioneer AVH-X491BHS

PPI PC 4800.2

Morel Maximo 6.5" x2

Share this post


Link to post
Share on other sites

Check your voltage, check it at the front and at the rear while under load just to make sure you don't have a bad connection for that 3500.1

 a lose/bad connection will reduce the available current going to your amp, most amps clip easier when it doesn't get its rated current.

Get rid of the cap & replace it with a battery if/when you can. 

Make sure your rca's and bass knob aren't accidentally pinched or grounded anywhere and shut off any bass boost/enhancement feature if you have any.

If it still clips at the very second at low volume, I'd probably get the amp checked.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...