Jump to content
 
 

Sign in to follow this  

Recommended Posts

I've been on this form before about the same thing, but I thought it would be more appropriate to post here. I've purchased four DC Audio Level 1 12"s. I don't a box that looked very similar to Steve Meade's "Bucket O' Bass" series. For whatever reason, one of my Subs blew. The coil is burnt up, but the other three are perfectly fine. I want to know what happened, and if it'll be covered under warranty. I doubt it'll be covered under warranty but it just seems to be a little suspicious that it was the only one that blew. Doesn't make any sense to me. Based on kirchhoff's law, shouldn't they all be taking equal current? I used Rockford Fosgate wiring wizard to make sure I wired it right. It was both me and my dad wiring it together, two set of eyes on this. I doubt we wired it wrong, wiring is super easy and my dad has done it all his life lol. I can send pictures of the sub and box. Also, the amplifier is not crazy over powered. It only has 100 extra watts per sub. Which it's always good to have Headroom. And no, I am not using the gain as a volume knob. I set my gain right. The app that I'm using is a QCA4000D, 2000w rms. I set the gain at 49v. E=√P•R  E is volts, P is desired wattage, and R is resistance. I used that formula. E=√1200•2, E=√2400, E=48.989, That means, my AC output at max volume should be 48.989 (49 is fine). That's correct right? I doubt I screwed up that bad with simple gain settings. Also, if the amp is the problem, why would it only attack one subwoofer and not all of them? This doesn't make any sense... I'm kind of new to this, but this is seriously confusing me. Can anyone help?

Share this post


Link to post
Share on other sites

Also, when I did my first test bump, (when the sub blew), I didn't have the volume up. The subs were moving less than a centimeter. They were barely moving! I was only doing it to get a rough idea of what it would sound like. Just making sure I tuned the box properly. (And I did) 34hz.

Share this post


Link to post
Share on other sites

Need to see pics of the box , sometimes airflow internally forces one sub to unload because all the pressure inside pushes more on that sub, but u said u also didn’t have them turned up so maybe not, If this was the first time they were fired they will be warrantied . Could have been a bad sub . Still would like to see pics and have your box specs.


3 Sundown SA-10's D4 ohm

American Bass VFL 120.1 Running at .6 ohms

250amp alternator

Mids all Alpine type R 's 2 set's of 6.5 components and 1 set of 6x8's 

3 Rockford PBR's 300x2

6 Kinetic batteries

F150 Supercrew 2010

Share this post


Link to post
Share on other sites

If it’s first sub seeing the power before the others that could be it

amp can be set wrong can’t math away distortion 

 

can be a box issue as well

Share this post


Link to post
Share on other sites
2 hours ago, Ron36 said:

Need to see pics of the box , sometimes airflow internally forces one sub to unload because all the pressure inside pushes more on that sub, but u said u also didn’t have them turned up so maybe not, If this was the first time they were fired they will be warrantied . Could have been a bad sub . Still would like to see pics and have your box specs.

Burnt coils rarely get warrantied coils don’t just burn themselves 

  • Like (+1 Rep) 1

Share this post


Link to post
Share on other sites

That amp is junk like I said before it’s not doing 2000rms..if you don’t believe me send it to bid d wiz ... . if you did the math the way you did for 2k no you didn’t do it right and no 49 wouldn’t of been ok and even with good amps it would of been better to go lower the higher so shouldn’t of went higher then the 48.9.. regardless... 

 

 

on a on a different note it’s looks like it’s only a 2 ohm stable amp you can still pick them up new at for $230

https://www.beachaudio.com/Quantum/Qca4000d-p-105824.html

Edited by CstrokerV

Share this post


Link to post
Share on other sites
On 3/16/2019 at 8:49 PM, CstrokerV said:

That amp is junk like I said before it’s not doing 2000rms..if you don’t believe me send it to bid d wiz ... . if you did the math the way you did for 2k no you didn’t do it right and no 49 wouldn’t of been ok and even with good amps it would of been better to go lower the higher so shouldn’t of went higher then the 48.9.. regardless... 

 

 

on a on a different note it’s looks like it’s only a 2 ohm stable amp you can still pick them up new at for $230

https://www.beachaudio.com/Quantum/Qca4000d-p-105824.html

Doesnt matter if its doing 2k rms, it only needs to do 1200. So, once again, doesnt matter. Also, I did the math the exact way that was shown to me from Sonic Electronix. Someone last I've always done their gain settings wrong, then idk. I didn't have it set at 2000 I had it set at 1200. Ill check it again though. But even if this were a gain problem, why is it that only one sub blew and the rest are perfectly unscathed? Alluding to basic electrical rules, each part of the circuit should take an equal amount of voltage. Not to mention that the volume was only a 1/4 of the way up.

Share this post


Link to post
Share on other sites

And the amp could of been still clipping at that voltage you set at that 1200 watts... and one sub going is not unheard of due to clipping with the other subs being fine.  if that amp is only capable doing say  800 rms of clean power and you set it to 1200 rms then you clip the amp to hell and back ... box could of been an issue also... burnt coil is rarely due to manufacture defect and to user error 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

SMD Chat Room

SMD Chat Room

Please enter your display name